5

On some browsers users are unable to login. Users also don't get feedback. The Magento system just doesn't respond. Sometimes the login does work in incognito mode.

Some things I already checked - formkeys are integrated in the forms - "web/cookie/cookie_domain" are for all storeviews set to null. - We run multiple storeviews eg; example.com/en/ , example.com/de/

I also tried modifying the cookie settings in the code as suggested on this url http://blog.chapagain.com.np/magento-admin-login-problem/ (however this article is related to the magento admin, where our problem is the frontend) but also that didn't work.

  • When did the problem came? You've changed something? Does it work with the default theme? – Roy Aug 13 '15 at 13:14
  • We put online our new shop, then the problem started to exist. It's the liveserver, on our devserver the problem does not exist (same code) and is running the same template. – Willem Rabsztyn Aug 13 '15 at 13:23
  • 1
    Maybe you're using SSL which causes the problem? – Roy Aug 13 '15 at 13:24
  • I use SSL but how can it cause a problem? (sometimes in incognito work it works with SSL) – Willem Rabsztyn Aug 13 '15 at 13:27
  • Check the cookies in those browsers. Might be they have cookies for domains .www.example.com as well as .example.com which conflict – Sander Mangel Aug 18 '15 at 7:05
5

It can be a problem in your template. You need to include form key in following templates:

1) app/design/frontend/[your_custom_theme]/template/customer/form/register.phtml
2) app/design/frontend/[your_custom_theme]/template/customer/form/resetforgottenpassword.phtml
3) app/design/frontend/[your_custom_theme]/template/persistent/customer/form/register.phtml
3) app/design/frontend/[your_custom_theme]/template/persistent/customer/form/login.phtml

<?php echo $this->getBlockHtml('formkey') ?>

Source: http://www.webspeaks.in/2016/02/magento-1-9-2-cannot-create-account-on-frontend.html

4

The solution for my issue was that there were two cookies

  • www.shop.com
  • .www.shop.com

These were conflicting. After setting the "web/cookie/cookie_domain" to "www.shop.com" there was only created one cookie, and the problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.