2

Our store returns a 404 error on every possible request. I've tried cleaning cache, indexes, redis, etc.. But no success. (NB Cache was already turned off) I deployed all the files (works on local) again to be sure there was no error in a file. But still there was a 404 error. When I tried running the Dev database on the live server the site runs perfectly. So I reckon it's a database issue of the live database.

When I tried to use the core_config_data table of the dev database, the shop still doesn't function and returns a 404 error on every request. So I suppose it is not a config error as well. I tried the same with the core_url_rewrite table (lots of relation errors), but still 404 everywhere (frontend + admin).

Another very interesting fact is that the shop is still running from the Chrome browser of my colleague (but only that specific browser).

1

I did not had a default store_view anymore because I renamed it to EN, my colleague had probably a cookie referenced with running the storeview EN.

I added in my nginx host map file the following to fix the issue:

map $host $storecode {
  hostnames;
  default en;
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.