In a Magento CE v when an order is marked as Suspected Fraud we then go in and look at the order to verify it. We then click the Get Payment update button (after manually approving the order in Authorize.net.

However clicking he Get Payment update button results in a message saying "There is no update for the payment." Also the order becomes marked as "complete" even though we would want the order status to change to say "Processing"

We are not sure what changes need to make to fix this? I have opened up the app/code/core/Mage/Paygate/Model/Authorizenet.php file and changed line 38 to read as const CGI_URL_TD = 'https://api.authorize.net/xml/v1/request.api';

However that did not fix the issue with no payment data being update?

2 Answers 2


I finally found a solution after struggling for a good long time.

Solution (At least for me)

Login to your merchant account on authorize.net

Click 'Account' Tab along top

Under 'Security Settings' Section

Under 'General Security Settings'

Click 'Transaction Details API' link

Follow instructions to Enable it, it is disabled by default.

Go Back to Magento Admin

Get payment update should now work.

  • thank you. I will do this and hope it resolves it for me.
    – Jayreis
    Commented Dec 2, 2015 at 21:28
  • I have a similar problem but in my case when there is any transaction is mark as Suspected Fraud in Authorize.net, Magento is not showing that order in Admin at all. What could be the reason for this type of issue ? Commented Jun 16, 2017 at 4:36

Not exactly the answer to the question but it seems a lot of people get to this question because of the url mismatch (like me). So I'm posting the correct solution to that here too:

Mage_Paygate_Model_Authorizenet is broken. You need to replace the request url. Although its a core bug I recommend to fix it with a little helper module:


<?xml version="1.0"?>


<?xml version="1.0"?>


class YourModule_Overwrites_Model_Paygate_Authorizenet extends Mage_Paygate_Model_Authorizenet
 // Copy Magentos core class content here
 // but replace const CGI_URL_TD
 // with
 // const CGI_URL_TD = 'https://api.authorize.net/xml/v1/request.api';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.