4

Our Magento store is running on an NGINX server & HHVM.

I've noticed that when you go to System > Manage Currency Rates the currency fields are displayed in the wrong order, they've all been shifted to the right.

Our base currency is Euro but the field with the euro rate is displayed beneath the GBP column.

They are: enter image description here

As opposed to: enter image description here

When I inspect the field with the 1.000 curency rate it has name="rate[EUR][EUR]" for which confirms the fields are in the wrong position.

There is nothing showing up in my HHVM or NGINX error logs.

Also I have hhvm.enable_zend_sorting = 1 & hhvm.enable_obj_destruct_call = 1 set in my /etc/hhvm/php.ini and /etc/hhvm/server.ini files.

Has anyone else using HHVM and Magento noticed this or have a solution?

2 Answers 2

2

As recommended by Daniel Sloof here:

http://youtu.be/BfTx2hWgylM

You should enable the support for Zend PHP alike sort stability using:

hhvm.enable_zend_sorting = 1

inside:

/etc/hhvm/php.ini

or:

/etc/hhvm/server.ini

More info on this and other switches here:

https://github.com/facebook/hhvm/wiki/INI-Settings

2
  • thanks for the links. I already have hhvm.enable_zend_sorting = 1 in my ini files but am still getting this issue. Do you experience this issue with HHVm & Magento?
    – Holly
    Aug 5, 2015 at 14:32
  • FYI this issue will be fixed in next release of HHVM, see my answer.
    – Holly
    Aug 6, 2015 at 12:23
2

reported the issue to HHVM on GitHub and interestingly while this error is occurring on recent versions of HHVM it is not on there latest nightly and should be fixed in version 3.9 of HHVM which is to be released sometime this month.

UPDATE

Confirmed that this solution worked when I I upgraded to version 3.9 of HHVM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.