0

i can't install any extension. Magento Connctor 2.0 stops the Installing Process at 'Checking dependencies of packages' There isnt any other thing showing up.

I already checked the file permissions(setting everything to 777 wouldn't help). I followed This and nothing Changed. After Hours of googleing and testing I made a fresh Install and same Problem again.

So i found the Failure..... Someone Installed the domain for typo3 not magento... Thanks everyone for your Help :)

closed as off-topic by Fabian Schmengler, Qaisar Satti, Raphael at Digital Pianism, Amit Bera, Marius Apr 6 '16 at 7:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Fabian Schmengler, Qaisar Satti, Raphael at Digital Pianism, Amit Bera, Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • May be redundant, but have you disabled cache and compilation? see gotgroove.com/ecommerce-blog/magento-development/… ; can you try to install your module manually? – nicolallias Jul 29 '15 at 12:04
  • @nicolallias Yes i disabled cache and compilation. i installed the modul manually without any problems. – LearningByDoing Jul 29 '15 at 12:15
  • What about manual install? Also, how many space is left on your server's disks? (on linux use command 'df -h') – nicolallias Jul 29 '15 at 12:17
  • @nicolallias Manual install works fine. Space is more then eneugh(50gb) :) – LearningByDoing Jul 29 '15 at 12:21
3

You might want to try to do a manual install:

  1. Convert your magento connect 2.0 to a direct download: http://freegento.com/ddl-magento-extension.php
  2. Open your FTP client and upload the extension in your Magento folder

No files should be overwritten,

Flush magento cache and then log out and back into magento backend

Go to configuration > advanced to check if module is listed and enabled

  • 1
    I tested this and it works. But i hope that i find a way to get the connector working. – LearningByDoing Jul 29 '15 at 12:30
  • Use this Magento Cleanup to fix all permissions and try the connector again: github.com/IndiesServices/Magento/blob/master/… upload this in your magento folder SSH into your server goto magento folder and type: php magento-cleanup.php – Sofian Jul 29 '15 at 13:06
  • Done it. But same Problem again. Stops at 'Checking dependencies of packages' – LearningByDoing Jul 29 '15 at 13:21
  • Did a google for you seems to be related to php and gzip: Go to downloader/lib/Mage/Archive/Helper/File/Gz.php in your Magento directory and replace "$this->_fileHandler = @gzopen($this->_filePath, $mode);" with "$this->_fileHandler = @gzopen64($this->_filePath, $mode);" The alternative to doing this involves recompiling php – Sofian Jul 29 '15 at 14:29
  • I tested this and it diddnt help. I started google at 9 this morning.... Something else I could do? – LearningByDoing Jul 29 '15 at 14:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.