0

I really screwed up this time! Problem is I don't know how, why and when.

When I open the edit/create attributes page (adminhtml) I get a blank page with header and a footer, but no error at all!

Obviously I checked google and have tried everything to figure out how this problem came to be, but I didn't find a solution.

What I tried (yes I cleared cache every time):

Enable logging (was enabled already), system.log and exception.log do not contain any logs that are relevant.

Enabled error printing in index.php:

error_reporting(E_ALL | E_STRICT);
ini_set('display_errors', 1);
ini_set('memory_limit', '512M');

Disabling every module I installed over the last week.

Enabled profiler To be honest I have no idea what I can learn from this

Somewhere on stackexchange I found somebody who had put this in his index.php:

ini_set('error_reporting', E_ERROR);
register_shutdown_function("fatal_handler");
function fatal_handler() {
    $error = error_get_last();
    echo("<pre>");
    print_r($error);
}

But after doing so I get the same message on every adminhtml page, and I don't think translation.php will be responsible for attributes not showing up.

Array
(
    [type] => 2
    [message] => vsprintf(): Too few arguments
    [file] => /public_html/app/code/core/Mage/Core/Model/Translate.php
    [line] => 416
)

Can anybody help me here!?

1

Since you are getting the header and footer, that means there is no fatal error somewhere in the code.
most probably a block does not exist or a template is removed or some layout file is corrupt.
If I remember correctly, the layout handle for the attributes add/edit page is adminhtml_catalog_product_attribute_edit.
This one is defined in the core in the catalog.xml layout file.
it should look something like this:

<adminhtml_catalog_product_attribute_edit>
    <reference name="left">
        <block type="adminhtml/catalog_product_attribute_edit_tabs" name="attribute_edit_tabs"></block>
    </reference>
    <reference name="content">
        <block type="adminhtml/catalog_product_attribute_edit" name="attribute_edit_content"></block>
    </reference>
    <reference name="js">
        <block type="adminhtml/template" name="attribute_edit_js" template="catalog/product/attribute/js.phtml"></block>
    </reference>
</adminhtml_catalog_product_attribute_edit>

check if it looks the same for you. Also check if the blocks listed there also exist. Specially adminhtml/catalog_product_attribute_edit (Mage_Adminhtml__Block_Catalog_Product_Attribute_Edit) and adminhtml/catalog_product_attribute_edit_tabs (Mage_Adminhtml__Block_Catalog_Product_Attribute_Edit_Tabs).
Also check if there is an extension that rewrites these blocks.
These blocks don't use special templates so you don't need to dig further if they exist.
Also check if something changes your admin theme. If so, check if the new theme contains the catalog.xml file and if it does check that it contains the layout handle mentioned above.

That's all I could think of right now.

0

You may have a badly formatted translation locale file in app/locale/xx_XX where xx is your default locale. Rename all the translation files you have recently updated to file.csv.disabled and refresh your cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.