0

How do I fix my Base URLs so I can access my Magento site?

I found a similar question that was already answered. I followed the steps but I still can't recover the website or get into Magento backend. I followed the steps and changed the secure and unsecure base url back to their original value. I cleared every var/cache and var/session folders as well. I still see this when trying to access the backend site:

Not Found

The requested URL /index.php/admin was not found on this server.

Help would be VERY much appreciated.

7
  • Do you have redis or similar caching system installed? Commented Jul 27, 2015 at 23:25
  • No, I do not have anything like that installed.
    – Cy44
    Commented Jul 27, 2015 at 23:29
  • I hope you have added / at the end of each url and can you give me your url if it is live. And also try without "index.php" (example.com/admin) Commented Jul 27, 2015 at 23:31
  • I did indeed add the trailing slash at the end of each url. www.cablings.com I also tried without "index.php" with no luck.
    – Cy44
    Commented Jul 27, 2015 at 23:36
  • From looking at your url I can guess you haven't correctly set those data for each fields (base url, skin, media etc) and also set these to 0: web/secure/use_in_frontend and web/secure/use_in_adminhtml Commented Jul 27, 2015 at 23:44

1 Answer 1

0

Not sure but if you have done everything it is your .htaccess problem.

Since you have installed magento in sub folder.

Go to .htaccess file and replace following:

#RewriteBase /magento/

to

RewriteBase /shop/

We have commented out the RewriteBase first and changed magento to shop. Hope this helps.

1
  • Once I figure out how to do that I'll let you know if it works. Most likely it will be tomorrow since it is currently past 9pm. Thank you for all your assistance.
    – Cy44
    Commented Jul 28, 2015 at 1:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.