2

What is the minimum version of Magento that exposes/supports a REST API and OAuth support?

Is there any support for REST API and OAuth in Magento 1.5.1?

  • It is possible to port REST API to 1.5.1 because in magento it is implemented as a wrapper on SOAP API (more or less). But I don't think time needed worth it, you should better update to 1.7. – Dmytro Zavalkin Sep 4 '13 at 18:45
  • @Zyava I agree. In this case, I am consuming the API and will not be modifying the Magento code itself. Thank you for the info though. – Ryan Gates Sep 4 '13 at 19:15
4

The minimum version for Rest API is Magento v1.7.0.0.

There should not be any Rest API in a clean version of Magento 1.5.1.0. I would expect it would be easier to plan an upgrade to 1.7 then it is to get Rest working on a 1.5 install.

Source

Magento 1.7.0.0 Release Notes

The Magento REST API: A Better Way to Integrate Business Applications

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.