0

I've done a update to Magento 1.9.2.0 - still after the update I get the error message at my item detail page.

Have anyone a idea to fix the problem?

    Invalid method DerModPro_BasePrice_Block_Catalog_Product_View::cacheSelf(Array
(
)
)

Trace:
#0 [internal function]: Varien_Object->__call('cacheSelf', Array)
#1 [internal function]: DerModPro_BasePrice_Block_Catalog_Product_View->cacheSelf()
#2 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Model/Layout.php(348): call_user_func_array(Array, Array)
#3 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Model/Layout.php(214): Mage_Core_Model_Layout->_generateAction(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#4 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Model/Layout.php(210): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#5 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Controller/Varien/Action.php(344): Mage_Core_Model_Layout->generateBlocks()
#6 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Cms/Helper/Page.php(113): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#7 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Cms/Helper/Page.php(52): Mage_Cms_Helper_Page->_renderPage(Object(Mage_Cms_IndexController), 'no-route')
#8 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Cms/controllers/IndexController.php(75): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'no-route')
#9 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Cms_IndexController->noRouteAction()
#10 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('noRoute')
#11 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#12 /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Core/Model/App.php(365): Mage_Core_Controller_Varien_Front->dispatch()
#13 /www/htdocs/w01325dc/oppacher-advent/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#14 /www/htdocs/w01325dc/oppacher-advent/index.php(83): Mage::run('', 'store')
#15 {main}
1

It looks like one of your modules, DerModPro_BasePrice, might be incompatible with Magento 1.9.2.0.

Go into etc/modules/DerModPro_BasePrice.xml and change <active>true</active> to <active>false</active>

Clear the cache and recheck.

If this module is the problem you should contact the module developer and ask if there is an updated version.

| improve this answer | |
  • Yes, I know. I have try this... but there is a new error: Fatal error: Call to a member function setData() on a non-object in /www/htdocs/w01325dc/oppacher-advent/app/code/core/Mage/Eav/Model/Config.php on line 651" – Pino Jul 25 '15 at 22:19
  • @Pino that one is most likely related to a config error. It doesn't give any module reference? magento updates are always a headache. – Claudiu Creanga Jul 25 '15 at 22:55
  • no, there is no reference. do you or anybody have no idea to fix the problem? – Pino Jul 26 '15 at 0:03
  • This is because the module added attributes which now reference non-existing attribute models. This link explains how to uninstall it completely: de.nr-apps.com/faq/content/21/92/de/… – Fabian Schmengler Oct 1 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.