0

I am wanting to use the Google Shopping Api from the github link below

https://github.com/bluevisiontec/GoogleShoppingApi

I have tried multiple times and followed all instructions without issue, but am getting a blank page in Admin. Error says:

a:5:{i:0;s:72:"Mage registry key "_singleton/googleshoppingapi/observer" already exists";i:1;s:1329:"#0 /home5/username/public_html/app/Mage.php(223): Mage::throwException('Mage registry k...')
#1 /home5/username/public_html/app/Mage.php(477): Mage::register('_singleton/goog...', false)
#2 /home5/username/public_html/includes/src/__default.php(22026): Mage::getSingleton('googleshoppinga...')
#3 /home5/username/public_html/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('controller_acti...', Array)
#4 /home5/username/public_html/includes/src/__default.php(14363): Mage::dispatchEvent('controller_acti...', Array)
#5 /home5/username/public_html/includes/src/Mage_Adminhtml_Controller_Action.php(160): Mage_Core_Controller_Varien_Action->preDispatch()
#6 /home5/username/public_html/includes/src/__default.php(14241): Mage_Adminhtml_Controller_Action->preDispatch()
#7 /home5/username/public_html/includes/src/__default.php(18698): Mage_Core_Controller_Varien_Action->dispatch('login')
#8 /home5/username/public_html/includes/src/__default.php(18228): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#9 /home5/username/public_html/includes/src/__default.php(21056): Mage_Core_Controller_Varien_Front->dispatch()
#10 /home5/username/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#11 /home5/username/public_html/index.php(83): Mage::run('', 'store')
#12 {main}";s:3:"url";s:17:"/index.php/admin/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

Any ideas on how to fix this?

2 Answers 2

1

Rename(Disable) extension from App > etc > moduels. Clear cache and then Run Compilation.

Maybe this is the problem.

1
  • Excellent. That worked! Deleting the app>bluevisiontec folder let me back into Admin. Then I deleted app>etc>modules>bluevisiontech. Then I disabled Compilations, re-uploaded the missing files and logged out then back in to Admin and everything is there and working. Thank you!
    – k1rah
    Jul 25, 2015 at 5:02
0

I believe the observer names defined in the config.xml should be unique and not the same. Although I could be wrong.

That said, I can't find any version this module supports, but see it's been recently updated.

Also, it could be the fact you are using compilation and the module doesn't support it. It's also best to just use APC or Aoe_ClassPathCache module or using a new version of PHP with an Opcode cache already included, as compilation tends to break a few 3rd party modules.

1
  • Well disabling Compilation definitely seemed to help. Everything works, EXCEPT I am getting an error when trying to manage products... Instructions say to set a store view for Oauth, but I don't see those settings anywhere and instead get an error: a:5:{i:0;s:77:"Error refreshing the OAuth2 token, message: '{ "error" : "invalid_grant".... The error message is too long to post here, but starts out as posted. I can't believe Magento doesn't have Google Merchant Feeds by default and it's really ruining my sales compared to the last platform I used.
    – k1rah
    Jul 25, 2015 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.