2

I can't figure out what this error message is in the system.log file. Have open the Gd2.php file looking at lines 492 and 513 and it has something to do with image watermark?

2015-08-15T20:24:41+00:00 ERR (3): Notice: A non well formed numeric value encountered in /home/.../magento/lib/Varien/Image/Adapter/Gd2.php on line 492
2015-08-15T20:24:41+00:00 ERR (3): Notice: A non well formed numeric value encountered in /home/.../magento/lib/Varien/Image/Adapter/Gd2.php on line 513

p.s. The files is getting very large with the same two lines above! It's about 119116 records.

  • Were you in backup in admin? This post has the same error, maybe it could help magento.stackexchange.com/questions/73205/… – Michael Jul 24 '15 at 16:13
  • @kaska thanks for the link. No I was not in admin>backup. Looking at the log for today's date 2015/07/24; it created error ERR (3): Notice: A non well formed numeric value encountered at the following times: 2015-07-24T00:26, 2015-07-24T01:08, 2015-07-24T02:06, 2015-07-24T03:19 and last one at 2015-07-24T05:07. These errors were generated after midnight, when admin was not used! – user2774042 Jul 24 '15 at 16:30
  • This doesn't happen while backing up in admin. I use the host cron to backup the database, and not admin! – user2774042 Aug 15 '15 at 20:35
4

Remove % from 'Image Watermark Opacity, Percent'. Just put in a number, like 15.

  • Solved. After about 4.5 months you solved it for me in 2 seconds. The system log file size grew to 300-350 MB every other week! Thanks. – user2774042 Dec 29 '15 at 16:26
0

Please Check your

[MAGENTO_ROOT_DIR]/app/design/frontend/default/etc/view.xml

for space between or after the numerical values, If any please remove them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.