1

i've setup magento CE 1.7.0.2 on a webserver nginx on 12.04 ubuntu cloud server. i've change configuration in order to use cdn for media, skin and js but i have some issues. for instance i can't upload new images for the product. no error shown, but the link of image is broken. i've just started using magento so maybe i'm doing something wrong but can't figure out what.

1
  • There is no support CDN in magento out of the box. OnePica_ImageCdn extension is good by its functionality is quite limited. With this extension You still must have full copy of all files in media folder. – Dmytro Zavalkin Sep 4 '13 at 10:00
4

Some elements of the image uploader and the wysiwyg content editor are served from within your ‘skin’ directory – which is now served from your CDN, and will start throwing cross domain errors.

The Unsecure URL settings configured in the default config (top left) in the admin section. Are global – they affect all the stores and the admin area. In order to disable the CDN on the admin, but keep it for the website, change the scope of your configuration to Main Website (top left), uncheck the ‘Use Default’ settings, and then add in the CDN urls.

So under Current Configuration Scope: Default config you should use ;

http://www.yourdomain.com/

Under Current Configuration Scope: Main Website and default store view you should use

http://cname.yourdomain.com/

they should look like this enter image description here enter image description here enter image description here

I’ve created Cname records to map to the cdn url’s (it’s neater) but you can just use the cdn urls if you prefer.

You can see a full explanation of the fix here

0
1

If you're using a CDN url for your javascript (eg: cdn1.example.com) it might be a crossdomain issue. Javascript won't be executed when the source is on a different domain. This might help: http://www.adobe.com/devnet/articles/crossdomain_policy_file_spec.html

If you're using a different kind of CDN, please tell us what kind of extension you're using for that. For example OnePica

1
  • my mistake, i thouught was good out of the box. i'll use OnePica_ImageCdn.many thanks – springerin Sep 4 '13 at 16:19
0

This is a bug in Magento and should be fixed

The location of the SWF for uploading should be harcoded to the current domain (bug reported and acknowledged)

There are some more locations where this can cause a problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.