1

we have a magento site

we have a large database of 1000mb for that site.

when we try to import database through phpmyadmin.

its not uploading full databse, lot of tables will miss after uploading.

we are getting this error :

Script timeout passed, if you want to finish import, please resubmit same file and import will resume

we have a godadddy cpanel and phhpmyadmin.

is there any way to upload a full database size of 1000mb completely.

i am planning to change php.ini settings as mentioned in this link :

https://stackoverflow.com/questions/16707532/how-to-solve-time-out-in-phpmyadmin

but i can not able to find php.ini file .

is i have to edit the defualt magento phi.ini.sample

  • 1
    Why don't you use SSH? mysql import command simply does it's job for any db size. – MagePsycho Jul 23 '15 at 10:00
  • we are not that much comfortable with ubuntu commands – Baby in Magento Jul 23 '15 at 10:05
  • 3
    I'm voting to close this question as off-topic because it is not related to Magento, but to phpMyAdmin and MySQL in general – Fabian Schmengler Jul 23 '15 at 10:06
4

Don't import database dumps of this size with phpmyadmin. You should have SSH access, so upload the file with scp or sftp, then log into the server with SSH and import using the command line:

mysql -uUSERNAME -p DATABASE < path/to/dump.sql
  • okay, than we will try this now..... – Baby in Magento Jul 23 '15 at 10:05
5

If you dont have SSH Login.Try following script it will clear log data that will reduce the database size little bit. Then try to upload it

TRUNCATE dataflow_batch_export;
TRUNCATE dataflow_batch_import;
TRUNCATE log_customer;
TRUNCATE log_quote;
TRUNCATE log_summary;
TRUNCATE log_summary_type;
TRUNCATE log_url;
TRUNCATE log_url_info;
TRUNCATE log_visitor;
TRUNCATE log_visitor_info;
TRUNCATE log_visitor_online;
TRUNCATE report_viewed_product_index;
TRUNCATE report_compared_product_index;
TRUNCATE report_event;
TRUNCATE index_event;

If you still get the timeout then i suggest you to use the Navicat Lite to remotely access you database and upload the sql file so you will not get time out problem.Following url will help you

https://www.webenabled.com/using-navicat

2

Try splitting the database into smaller files. Depending on the size you could have one or more table per sql file.

phpMyAdmin is just very bad with large files. Heaven forfend you are using an outdated version of it as well.

1

If you have limited access to your installation - ask your hosting provider (GoDaddy) to make the necessary changes to php.ini to import your database correctly.

While I agree that SSH is the way to go, this option isn't always possible. There is nothing wrong with importing your database through phpmyadmin.

  • i will contact them to incraese php.ini settings – Baby in Magento Jul 23 '15 at 10:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.