2

This question already has an answer here:

Because I wanted to include shipping and return texts in different CMS pages in a magento website, I used static blocks and was adding the following code so i don't have to make edits in all of them but just the one block.

{{block type="cms/block" block_id="block_product_tab_shipping"}}
{{block type="cms/block" block_id="block_product_tab_returns"}}

Everything was working fine but with the latest magento updates i noticed that all those pages are now showing the same block. Even if i use different ones...

Every page are now show the shipping block. I noticed that after disabling cache everything worked fine.

Its weird because all the cms pages of a footer column is showing the same block, the other column is showing another block :S

Magento changed the way that those blocks are now cached?

Can i exclude only those blocks from cache to resolve the issue?

Do you have any other suggestion?

marked as duplicate by Rajeev K Tomy, Fabian Schmengler, liyakat, Marius Jul 23 '15 at 7:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

It is a confirmed issue in Magento 1.9.2

Problem is recent stable version (ie 1.9.2) included cacheing for static blocks, but it is not enough to uniquely cache each individual static blocks.

The solution is use this extension, which is created by me. You can get more details about the extension over there. You can either use the extension or use the same trick in your Magento instance.

0

I had to disable staic block cache right after doing the most recent upgrade to magento 1.9.2. Prior to that the blocks changed just fine. After that the blocks were showing up in all the wrong places. ~B.

Not the answer you're looking for? Browse other questions tagged or ask your own question.