2

I have Magento 1.9.2.0 with the sample data and default Madison Island store with 3 view names; English, French and German. In frontend when I switch the language using the select field, nothing happens! The frontend is still in English?

Shouldn't this select field switch the frontend language automatically? is there anything else that I should install since this is Magento and they do everything differently/complexly.

In Cache Storage Management I disabled it to all.

I'm on Windows 8 machine using Chrome browser and store installed through** http://127.0.0.1/** localhost

Update

I have downloaded the modules: Locale_Mage_community_fr_FR & Locale_Mage_community_de_DE and it seems to work, so please close the question :)

  • 2
    Have you created translation csv files? Downloaded the French and German language packs? Do you have your cache disabled? – SR_Magento Jul 20 '15 at 10:49
  • Isn't this done by default? I mean when you first install the Magento and sample data. If not why show the switch language box if no language is available/exist? – numediaweb Jul 20 '15 at 11:05
  • Glad I could help – SR_Magento Jul 20 '15 at 18:16
4

I finally fixed it after reading many tutorials about how Magento works. To save time and hair for future developpers, here's how to do it:

  1. Go to magentocommerce.com and search the language pack, like this one for french language: click Install now and use Magento connect 2 and then get extension key.

  2. Go to your admin: System -> Magento connect -> Magento connect Manager, Install New Extensions and put the key you got earlier, then follow the instructions there.

  3. Return to admin, then go: System -> Manage Stores. create Store view for the new language. You may need to refresh cache.

  4. Return to admin, then go: System -> Configuration. Choose your language in the Current Configuration Scope select box: Set local to your language in Local Options.

  5. Now we have to assign the front end home page to the new language, go to: CMS -> Pages. Search for title "Madison Island" click on it and in Page information, set Store View to All store views.

  6. Next step is to assign the products to that new language, go to: Catalog -> Manage Products. Select all and set action to Update attributes. In Websites -> Add Product To Websites, check Main Website.

  7. You may be asked to re-index data: System -> Index Management.

  8. Finally lets refresh and delete cache: System -> Cache Management and then logout/login.

This is how to do it :)

PS: I'll update later when I have time with screenshots for beginners to follow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.