4

These are the steps I took to move a live site to localhost

ssh in to live site as root cd to directory of site dump database using mysqldump -u -p db_name > db_name.sql.gz cd one directory up compress site's directory using tar -zcvf site.tar.gz /site

ftp in as root download db_name.sql.gz download site.tar.gz

move files to wamp/www/

extract tar file with 7zip (you have to unzip the .tar.gz file first, then extract the .tar file)

open app\etc\local.xml in a text editor and configure the following parameters (is that the right use of the word "parameters")

I don't have a password set up in my localhost so I just put in root and left the password field blank

use browser to go to localhost/phpmyadmin/

create a new database with the name defined in the local.xml file

This part took a long time for me to figure out.

My compressed database was too big to import via phpmyadmin, so I figured I'd have to do it through the mysql console. But I couldn't unzip the database through 7zip (I got the "cannot open file as archive" error) I tried downloading the

the 7za command line version of 7zip but I got the same error. The internet told me to try gzip but sourceforge.net was down for maintenance and I couldn't find it anywhere else.

Finally, from Yahoo answers of all places, I got the idea of renaming the file from dump.sql.gz to dump.sql

That worked. By now it was 9:15pm (I started this whole project at 5pm)

So I went to MySql console by clicking on wamp icon in taskbar MySql> MYSQL Console and ran this command:

mysql> use DB-NAME mysql> source [absolute path to .sql file (starting with c:\ etc)

mysqlconsole did its thing and it seemed to be going well.

I went to phpmyadmin and sure enough the database was there!

opened up the core_config_data table and edited the base_url values to my local directory (in my case localhost/empbackup/staging)

I did the same for the mgnt_core_config_data table

now I browse to localhost/empbackup/staging

and I got an internal server error

the apache_error log said my .htaccess had an invalid command (AddOutputFilterByType) - perhaps misspelled or defined by a module not included in the server.

I backed up the .htaccess file and opened it in a text editor, found that command and it was inside an IfModule:

AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript
AddOutputFilterByType DEFLATE application/xml application/xhtml+xml application/rss+xml
AddOutputFilterByType DEFLATE application/javascript application/x-javascript
#AddOutputFilterByType DEFLATE application/x-httpd-php

BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
SetEnvIfNoCase Request_URI \.(?:exe|t?gz|zip|bz2|sit|rar)$ no-gzip dont-vary
SetEnvIfNoCase Request_URI \.(?:pdf|doc)$ no-gzip dont-vary
SetEnvIfNoCase Request_URI \.(?:avi|mov|mp3|mp4|rm)$ no-gzip dont-vary

I checked the apache httpd.config file and the "LoadModule deflate_module modules/mod_deflate.so" was present and enabled.

I deleted the module. refreshed the browser and I got the Magento "There has been an error processing your request"

Exception printing was disabled, so I went to /errors and renamed local.xml.sample to local.xml Refreshed browser:

Illegal scheme supplied, only alphanumeric characters are permitted

Trace:
#0 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\Store.php(777): Zend_Uri::factory('localhost/empba...')
#1 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Controller\Varien\Front.php(332): Mage_Core_Model_Store->isCurrentlySecure()
#2 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Controller\Varien\Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#3 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#4 C:\wamp\www\empbackup\staging\app\Mage.php(684): Mage_Core_Model_App->run(Array)
#5 C:\wamp\www\empbackup\staging\index.php(87): Mage::run('', 'store')
#6 {main}

searched online for "Illegal scheme supplied, only alphanumeric characters are permitted"

and found a stackoverflow post by Anton S. :

https://stackoverflow.com/questions/7889286/magento-bug-illegal-scheme-supplied-only-alphanumeric-characters-are-permitte

So I searched for "rename localhost"

found this:

https://stackoverflow.com/questions/17652373/how-to-change-the-url-from-localhost-to-something-else-on-a-local-system-usin

Refreshed browser. got this:

Forbidden

You don't have permission to access /empbackup/staging/ on this server. Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80

Changed httpd.config to

#Options FollowSymLinks Options Indexes FollowSymLinks Includes ExecCGI AllowOverride All Order deny,allow Allow from all

Restart WAMP Refreshed Browser

404 Not Found

Went to local.staging

404 Not Found

Went to localhost

404 Not Found

I've been trying to set up my magento store locally for months now. I thought today would be the day, but no.

I think I've been very thorough and tried everything.

Please help and let me know where I'm going wrong.

Thanks!

PS if you decide to help me please be specific, I really don't know anything about programing and I need as much help as I can get.

--

Following @FROSIT advice, I reverted to the previous state of my hosts file and my httpd.config file.
Then I deleted local.xml to start a new Magento installation,

The installation was going normally until I go this error:

Error in file:

"C:\wamp\www\empbackup\staging\app\code\local\Mirasvit\SearchLandingPage\sql\searchlandingpage_setup\mysql4-upgrade-1.0.0-1.0.0.1.php" - SQLSTATE[23000]: Integrity constraint violation: 1022 Can't write; duplicate key in table 'm_searchlandingpage_store'

Trace:
#0 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\Resource\Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\Resource\Setup.php(422): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '1.0.0', '1.0.1')
#2 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\Resource\Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.0.1')
#3 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\Resource\Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\wamp\www\empbackup\staging\app\code\core\Mage\Core\Model\App.php(343): Mage_Core_Model_App->_initModules()
#6 C:\wamp\www\empbackup\staging\app\Mage.php(684): Mage_Core_Model_App->run(Array)
#7 C:\wamp\www\empbackup\staging\index.php(87): Mage::run('', 'store')
#8 {main}

This probably has to do with a search extension we have running on our live site.

Really all I want to do is set up the site on my computer so I can use it as a sandbox without having to touch the live site. Any help is greatly appreciated.

-- 7/21/15 Okay, I disabled the module and reran the installation, now the installation worked, however it emptied the database, so it's using the default magento template and has no products.

I read somewhere that this might have something to do with the indexing? Any ideas?

closed as off-topic by sv3n, Manoj Deswal, Jai, Dhiren Vasoya, Priyank Jan 31 '18 at 4:37

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – sv3n, Manoj Deswal, Jai, Dhiren Vasoya, Priyank
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Hey, try disabling this module by setting active to false in app/etc/modules/[themodule].xml I think it will skip the module at installation. Else you can maybe truncate this modules tables or completely delete them. First priority is getting your site to work, after we'll debug the module. You could also reach out the the developer. I have good experiences with Mirasvit, great modules – FROSIT Jul 20 '15 at 20:43
  • I suggest you should try reindexing your tables execute the command from your magento shell folder for reindexing cd /path/to/magento/shell/folder/ php indexer.php --reindexall – Ashish Ranade Sep 11 '15 at 9:03
  • It seems parts of the core_resource table are missing. Try re-importing the sql in a fresh database. – Milan Simek Oct 12 '15 at 18:38
0

Wow that's a lot of information. Seems you have some url problem. I usually just delete local.xml so you can install it again. Magento makes the necessary changes for you in the database. You won't lose anything. Be aware your base url ends with an / otherwise things go bad. If installation was succesfull try deleting your cache var/cache manually. you also should have your compiler disabled as a best practice. refresh your indexes, try it with the default .htaccess. create an index.html file and try to reach it in your browser. Sometimes using 127.0.0.1/ also works. If after this still something doesn't popup there's some server issue. Try installing xampp instead, don't temper with it just install like i explained above. place your database in xampp. delete local.xml and try to install it using the wizard. Let me now what you run into doing this :)

  • srry if above confuses you, im tired. If above makes no sense tell me and i write some step by step procedure for you. Seems to me you already have enough knowledge to solve it with the tips above :) – FROSIT Jul 18 '15 at 4:24
  • Thanks @FROSIT I took your suggestions and I edited the original post with the results. – ajjp5o7 Jul 19 '15 at 21:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.