1

Hi there I'm trying to install Magento 2, and i'm getting "The requested PHP extension ext-xsl * is missing from your system" please help

closed as off-topic by Keyur Shah, Fabian Schmengler, Keyul Shah, Marius Jul 16 '15 at 12:31

  • This question does not appear to be about the Magento e-Commerce platform within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I'm voting to close this question as off-topic because it is a general question about server configuration and better suited for serverfault.com – Fabian Schmengler Jul 16 '15 at 11:49
  • you can install it with sudo apt-get install php5-xsl – roman204 Sep 28 '15 at 14:23
  • Just comment here as a reference for other people: - sudo apt-get install php5-xsl (=> to install it) - sudo php5enmod xsl (=> to enable xsl) - sudo service apache2 restart (suppose you are using apache2, then need to restart it) – NgocDB Nov 30 '15 at 17:22
2

This is not a Magento 2 related issue. It's a server configuration issue.
The php extension xls is required in order to make Magento 2 work.
See details about how to install/enable it here

  • I have no idea how to get this file – Ben Anderson Jul 16 '15 at 11:00
  • Modify PHP.ini $vi/usr/local/php/etc/php.ini Extension=xsl.so Then restart the PHP service/etc/init.d/php-fpm restart Go back to/home/wwwroot/magento2 and execute it again. – The Dead Guy Jul 15 at 11:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.