5

There are, basically, two ways when importing product via csv file in Magento. a) import b) dataflow import

a) option, works faster, I assume that is because this option want index all the data on the fly, you have to do that after the import is done.

is there a way i can stop dataflow import to stop indexing on the fly. I think this will speed up the process of importation. Very important.

3 Answers 3

2

Try to set the indexes mode to Manual Update instead of Update on Save.

Also setIsMassupdate product flag is used in DataFlow import to prevent indexer to be triggered upon each product save method call.

4
  • sorry. but it did not help. As it was set to manual at the first place. Did not solve anything. Thanks anyway :=)
    – user15151
    Jul 15, 2015 at 14:25
  • Did you added the setIsMassupdate flag?
    – lloiacono
    Jul 15, 2015 at 16:01
  • Where to add the setIsMassupdate flag? May 13, 2016 at 15:42
  • Unless I'm missing something, this does not work.
    – HenryHayes
    Feb 26, 2022 at 13:53
1

For anyone tryign to disable the cache-clearing / indexing thats done after an import then go to file /app/code/core/Mage/Adminhtml/controllers/System/Convert/ProfileController.php and comment out the line $batchModel->beforeFinish();

Hope this helps someone.

0

I've created a module to override Mage_Dataflow_Model_Batch with MyModule_Override_Dataflow_Model_Batch. Overriden beforeFinish() and commented out $adapter->finish();.

This stops the pesky Please wait while the indexes are being refreshed. from happening.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.