2

I am trying to install Magento extension StitchLabs_ChannelIntegration but I am getting this error:

CONNECT ERROR: Package community/StitchLabs_ChannelIntegration 1.0.8 depends on PHP extensions: Array

My specs:

  • Magento 1.9.?
  • New Amazon EC2
  • Latest httpd and php55w

  • php -m shows:

    [PHP Modules]
    bz2
    calendar
    Core
    ctype
    curl
    date
    dom
    ereg
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    gmp
    hash
    iconv
    json
    libxml
    mbstring
    mcrypt
    mhash
    mysql
    mysqli
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Phar
    readline
    Reflection
    session
    shmop
    SimpleXML
    sockets
    SPL
    sqlite3
    standard
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib

    [Zend Modules]
    Zend OPcache

The only traction that I have made is that I have read that I need to add extension=php_xsl.so in php.ini but I don't have that installed cannot find anywhere to install this extension, only the dll version for windows.

trying to yum install php-xsl outputs:

Loaded plugins: update-motd, upgrade-helper Package php55w-xml-5.5.26-1.w6.x86_64 already installed and latest version Nothing to do

and searching for find / -name php_xsl.so outputs nothing

Please help

2

If I check the package.xml of the extension (version 1.0.8), then I see the following dependencies specified:

<dependencies>
  <required>
    <php>
      <min>5.1.0</min>
      <max>6.0.0</max>
    </php>
    <package>
      <name>Mage_Core_Modules</name>
      <channel>community</channel>
      <min>1.7.0.2</min>
      <max/>
    </package>
    <extension>
      <name>soap</name>
      <min/>
      <max/>
    </extension>
  </required>
</dependencies>

It depends on:

  • PHP version >= 5.1.0 < 6.0.0
  • package Mage_Core_Modules >= 1.7.0.2
  • extension: soap

When I see the list of installed PHP extensions, I believe I don't see SOAP in there (!)...

You can install it using:

yum install php-soap

Then add this line to your php.ini:

extension='/usr/lib/php/modules/soap.so'

If you need more help on installing PHP SOAP, I'd advise you to just Google it and you'll find what you need...

  • Thanks, although I tried that of course I googled for solutions for hours. Why would I post on a forum for help if it was on google? Anyway, I just switched over to Ubuntu and now I am not having any problems. Thanks – Gary Frey Jul 16 '15 at 22:25
  • @GaryFrey, the error says "depends on PHP extensions: Array" and the XML says "depends on SOAP" so that's what I found out. Your question did not provide any information on your attempts to install SOAP. Please add this to your question an provide what his happening after that (did php-soap install properly? can you install the module now? what errors do you get now?) – 7ochem Jul 17 '15 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.