I setup one Magento on Mypeer1.com server. My magento is having multistore with all the design layout same and just the category and theme color is different and i am going to have separate domain for each of my store.

everything is working fine on my staging server , so i moved on Mypeer1.com For now the site is in testing mode and not mapped to the domain so its working temporary in IP address.

The main site is working fine e.g and the inner store is setup like and same as other store and

now the issue is all other store is working for only home page and when i open the inner pages for all other store , it load the main store theme with 404 page.

I have placed the correct htaccess in the substore folder and setup the correct store code and other settings correctly. I am not sure why its loading home page for all sotre and not loading the inner page as well as any category and product pages.

Any help will be very much appreciated. Thanks

  • Pravin, did you get this fixed? I am having the same problem. I have checked my base urls, index.php for MAGE_RUN_CODE and mod_rewrite is enabled. What else can I check to fix this? I'm running out of ideas how to solve this.
    – Lucy
    Nov 3, 2013 at 16:29
  • Hi Pravin, Is your problem solved. Now we have the same issue. kindly tell how you have solved the issue?
    – alamelu
    Oct 8, 2014 at 12:54

2 Answers 2


I would suggest the following:

  • Check and set the base-urls (example.com), maybe you missed the trailing slash in your stores?
  • Create an entry for testing in your hosts-file (under Windows in `C:\Windows\System32\drivers\etc\hosts), so you can test with a domain and not IP-address example.com

  • you talked about substore folders: Does this mean you have subfolders like store2, store3, store4,... where you set the MAGE_RUN_CODE? Check if you've got maybe the wrong address/ip in the RewriteCond.


Make sure you have mod_rewrite enabled on your server.

  • I already checked it and its enable. Sep 2, 2013 at 6:12
  • What about AllowOverride All? If it's set to None then it will ignore your .htaccess Sep 2, 2013 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.