magento assistance needed to help me to resolve ssl issue i'm facing on my magento store, i'm using Magento ver. and i just notice https issue on my site, whenever i'm trying to loading any of my website page, using below links formate, it redirect me on home page.

http www.example.com/page (Working) https example.com/page (redirect on home page) http www.example.com/page (redirect on home page) http example.com/page (redirect on home page)

Thank You

  • "http www.example.com/page (Working) " ... "http www.example.com/page (redirect on home page) " - what? Commented Jul 13, 2015 at 21:11
  • "http www.example.com/page (Working) " but when i add HTTPS "https www.example.com/page (redirect on home page) "
    – Sam
    Commented Jul 13, 2015 at 21:34
  • Are you using apache or nginx? Can you post your vhost config files? What about the secure and unsecure url in core_config_data, what values do you currently have there? Did you make any changes to your .htaccess?
    – lloiacono
    Commented Jul 14, 2015 at 8:45
  • base url or rewrite rule - something incorrect
    – user2857
    Commented Jul 14, 2015 at 11:50

1 Answer 1


First off just make some changes in .htaccess Search for Options +FollowSymLinks And put below code under it:

RewriteEngine on

RewriteCond %{HTTP_HOST} ^example.com [NC]

RewriteRule ^(.*)$ http://www.example.com/$1 [L,R=301,NC]

RewriteCond %{SERVER_PORT} 80

RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L]

If this do not work then you will have to check with second option.

Second you need to check your ssl.conf under your server virtual host directory nginx or apache: Example:

cd /etc/apache2/sites-available

sudo nano example_ssl.conf

(example is domain reference for ssl, it can be anything you want.) just check your site directory and https url configuration for domain name and url

Run this to enable and start SSL on server for above configuration:

sudo a2enmod ssl

If you have anything to change in ssl.conf you will have to restart the server:

sudo service apache2 restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.