2

Patched Magento with SUPEE-5994 and was successful. After clearing cache and clearing and disabling compilation site worked fine.

I then patched with SUPEE-6285 and whilst indicating it was successful in the ssh console i now can not access either the store or admin. The HTTP error log shows the following...

PHP Warning: require_once(/var/www/html/app/Mage.php): failed to open stream: Permission denied in /var/www/html/index.php on line 69

PHP Fatal error: require_once(): Failed opening required '/var/www/html/app/Mage.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/index.php on line 69

2

failed to open stream: Permission denied

Try to set permissions as following

for magento 1.5+

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
chmod o+w var var/.htaccess app/etc
chmod 550 mage
chmod -R o+w media

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.