6

I am facing some weird issue. I cannot disable PayPal express checkout on my Magento store running on 1.9.1. I have checked in another version of Magento. The only difference I found is the current store has Merchant Country as Thailand where as other have a country as United state. Please guide me to get this issue solved

  • what did you tried to disable the payapal? – MeenakshiSundaram R Jul 13 '15 at 6:43
  • 2
    I am not getting option to paypal express when I enable PayPal Standard – Pratik bhatt Jul 13 '15 at 6:45
5

Finally I found answer to the question

update core_config_data 
set value = '1' 
where path = 'payment/paypal_standard/active';

by this I could enable only paypal standard

|improve this answer|||||
  • I found the path to be the one below, and not this one. – Goose Jan 27 '16 at 14:14
  • You just run this query in sql – Pratik bhatt Jan 27 '16 at 14:42
  • That path doesn't exist, at least not in my instance of 1.9.0.2. The path in the query in the other answer does exist and works. – Goose Jan 27 '16 at 16:14
4

After configuring Paypal Standard the option to configure Paypal Express becomes disabled:

image

Trying running this query:

SELECT * FROM core_config_data WHERE path = 'payment/paypal_express/active';

Are any of the values 1? Try changing them to 0 and see if that gets the desired result.

|improve this answer|||||
  • This works for me. Thanks :) But Is it a proper mean to accomplish this ? There must some reason behind disabling Configure button in the CMS. – Kumar A. Aug 8 '16 at 10:03
2

Another way, found under the paypal payment settings

system->configuration->payment_methods->paypal

is the advanced settings link for Express checkout, under the Basic Settings-PayPal Express Checkout.

Set the dropdown Payment Applicable From to Specific Countries, and then don't select any countries from the Countries Payment Applicable selection area. It will effectively disable paypal express and remove the option from the onepage checkout.

|improve this answer|||||
1

Problem solved.

ENABLING PAYMENT STANDARDS

You can easily enable Payment Standards in Magento 1.9 by running the below database query:

update core_config_data set value = 1 where path = 'payment/paypal_standard/active';

DISABLE PAYPAL EXPRESS

update core_config_data set value = 0 where path = 'payment/paypal_express/active';

then it will work fine

|improve this answer|||||
1

There's two options I need to disable to show Paypal Standard without express checkout option under the System -> Configuration -> Payment Methods -> Website Payments Standard (Includes Express Checkout):

1) Display on Product Details Page
2) Advanced settings -> Display on Shopping Cart

I set both to No, flushed the cache and I don't see paypal express on product page, cart and checkout. But Paypal standard is still there on checkout.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.