2

I've tried for hours to get Magento running on my webspace, but it just doesn't work.

I already have it running locally with xampp and everything seems to work fine.

When I upload the files and the database and change the mysql connection data and the base url in the db, I get the index page without proper style and formatting and without images and the links don't work, I always get a 404 error.

I tried to reinstall by deleting the appropriate files, but somehow I get either a database connection error or the error message that says invalid url. The index page was able to connect and I know the connection information is right.

Has anyone an idea what the problem might be or where to look for further information? Here's the phpinfo() output: http://gyazo.com/300e884f8837bc98f64474695f5974d0

  • Check the rendered source for your homepage. Where are the URLs for the CSS pointing? – benmarks Jul 13 '15 at 1:14
  • .htaccess in root folder ? – user2857 Jul 14 '15 at 11:48
2

1) Turn on Developer Mode on your remote instance.

2) Make sure you aren't uploading transient files (i.e. the transferred ./var/ should contain nothing).

  • Thanks for your reply, I've tried another upload and it seems to work better if I replace every occurence of "localhost" in the sql file before upload, rather than just changing the 2 values in the configuration table as stated in one of the instructions. Now I still have the problem with the url-rewriting. I only get 404 pages when it's activated. I already tried to alter my .htaccess file accordingly and I know that the server supports url rewriting. Any Ideas? – user1563232 Jul 13 '15 at 12:56
  • "it seems to work better if I replace every occurence of "localhost" in the sql file before upload" is a scary statement. What do you mean?? Regarding rewrites & 404 you need to make sure that your remote config is set correctly for that server's settings. Also, make sure that you are including .htaccess from the root folder. – benmarks Jul 13 '15 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.