1

I installed patch file on server in directory where all magento files are

than in ssh i wanted to run the patch

i got an error

this is last part of code (it says there is mo folder app/ect/ but it is there??)

What could be causing the issue?

I use Magento 1.9.1.0

 ./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 32: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 33: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 34: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 35: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 36: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: wc: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 32: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 33: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 34: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 35: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 36: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: Resource temporarily unavailable
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: wc: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 32: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 33: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 34: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 35: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 36: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: Resource temporarily unavailable
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 25: ((: > 0 : syntax error: operand expected (error token is "> 0 ")
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 32: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 33: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 34: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 35: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: line 36: which: command not found
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: retry: No child processes
./PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh: fork: Resource temporarily unavailable
ERROR: "/app/etc/" must exist for proper tool work.
bash-4.2$          
5
  • Did your download complete successfully? You may have a corrupted file. Also have you placed the patch file within the same folder as index.php? – Dave Jul 9 '15 at 12:01
  • Yes i downloaded it (i am on a mac so i got message it could har the computer and if i want to keep the file, answered yes) i uploaded it to the folder where index.php is... the file mentions 1.9.1.1 above... i have 1.9.1.0... could that be it? Though the file was for 1.9.0.0. up to 1.9.1.1 – Carlo Jul 9 '15 at 12:13
  • strange, because i did the previous patches with no issues in May – Carlo Jul 9 '15 at 12:21
  • Maybe you have something else, than a bash? try sh PATCH-SUPEE... – Fabian Blechschmidt Jul 9 '15 at 12:26
  • @FabianBlechschmidt don't know what you mean but i see bash-4.2$ don't know what that means though... i'm not good with this stuff unfortunately. – Carlo Jul 9 '15 at 12:28
2

As Dave suggested: Make sure, that you loaded the complete, error-free PATCH file.

Second: don't give chmod +x and run it directly ./PATCH-SUPEE... but instead use a shell wrapper like this: sh ./PATCH-SUPEE...

4
  • would it need to be like you state or would it be: sh PATCH_SUPEE-6285_CE_1.9.1.1_v2-2015-07-08-08-07-43.sh ... so without ./ - i read in this forum and also from host that i needed to do it like that... and no chmod?? – Carlo Jul 9 '15 at 15:30
  • sh will call the script inside the file, so no need to chmod, as long as you can read it. and sh is directory specific, so it doesn't matter whether you use ./ before or not. – Fabian Blechschmidt Jul 9 '15 at 19:10
  • @FabianBlechschmidt could you ps help me how can i solve this error snag.gy/hWXebp.jpg – zus Dec 7 '17 at 6:18
  • @zus feel free to send me an email. I'm freelancer and happy to give you paid support. – Fabian Blechschmidt Dec 8 '17 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.