This question already has an answer here:

Just tried to load an extension through magento connect and had the error "Unknown cipher in list: TLSv1", the extension was Subcategories Grid/List by apptrian.

Have tried a few more extensions and the same error comes up. Magento 1.9.2

Anyone have a clue on how to approach this issue?

marked as duplicate by Ben Lessani - Sonassi, Keyul Shah, Mufaddal, Amit Bera, Marius Jul 11 '15 at 5:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • When is an upgrade not an upgrade? When Magento includes a downloader that's expecting SSL on a brand new version release when they've shut it off on the server. One of those "don't modify core code" things where you have to modify core code so it will work. – Fiasco Labs Jul 9 '15 at 3:50

I use "CENTOS PHP 5.4.43 cURL 7.19.7"

In downloader/lib/Mage/HTTP/Client/Curl.php, try changing:

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');



In file downloader/lib/Mage/HTTP/Client/Curl.php I changed the code

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); 



   $this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');


and problem will be solved for now.


This error occurs while trying to install a Magento Connect extension because Magento turned off SSLv3 on Magento Connect, but curl is still trying to connect with SSLv3.

In downloader/lib/Mage/HTTP/Client/Curl.php


$this->curlOption(CURLOPT_SSL_VERIFYHOST, 2);


$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');

It looks like your issue is related to: Connect Manager fails to download with SSL handshake error

Not the answer you're looking for? Browse other questions tagged or ask your own question.