1

I have now tried to perform an update to 1.9.2, which did not work. I tried to install the update via Magento Connect, then the side seemingly offline (Error 503) but the maintenance.flag file does not exist.

Then it looks at the Magento error log as follows:


a:5:{i:0;s:1008:"SQLSTATE[42S22]: Column not found: 1054 Unknown column 'e.status' in 'where clause', query was: SELECT COUNT(DISTINCT e.entity_id) FROM `mag19_catalog_product_flat_1` AS `e`
 INNER JOIN `mag19_report_compared_product_index` AS `idx_table` ON (idx_table.product_id=e.entity_id) AND (idx_table.visitor_id = '109')
 INNER JOIN `mag19_catalog_category_product_index` AS `cat_index` ON cat_index.product_id=e.entity_id AND cat_index.store_id=1 AND cat_index.category_id = '2'
 LEFT JOIN `mag19_core_store` AS `store_index` ON store_index.store_id = idx_table.store_id
 LEFT JOIN `mag19_core_store_group` AS `store_group_index` ON store_index.group_id = store_group_index.group_id
 LEFT JOIN `mag19_catalog_category_product_index` AS `store_cat_index` ON store_cat_index.product_id = e.entity_id AND store_cat_index.store_id = idx_table.store_id AND store_cat_index.category_id=store_group_index.root_category_id WHERE (e.status = 1) AND (cat_index.visibility IN(3, 2, 4) OR store_cat_index.visibility IN(3, 2, 4))";i:1;s:4858:"#0 /var/www/vhosts/domain.../httpdocs/lib/Varien/Db/Statement/Pdo/Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 /var/www/vhosts/domain.../httpdocs/app/code/core/Zend/Db/Statement.php(291): Varien_Db_Statement_Pdo_Mysql->_execute(Array)
#2 /var/www/vhosts/domain.../httpdocs/lib/Zend/Db/Adapter/Abstract.php(480): Zend_Db_Statement->execute(Array)
#3 /var/www/vhosts/domain.../httpdocs/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SELECT COUNT(DI...', Array)

and many more

Do you have an idea? I am grateful for any help.

marked as duplicate by Sander Mangel, Fabian Schmengler, Steve Robbins, Fabian Blechschmidt, mbalparda Jul 8 '15 at 22:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you confirm you downloaded all the updated files? Do you have a /dev directory? – brentwpeterson Jul 8 '15 at 20:09
  • Hello, yes, the directory dev exists. – davefinitiv Jul 8 '15 at 20:28
  • Run a reindex. If that doesn't fix it add the column to the database table by hand – Sander Mangel Jul 8 '15 at 20:31
  • The main cause was the one of the external Zendcache, I had it until empty via System -> Cache Management then only disable all caches. Before that I had at the end of the update a content Encodig error. So, at least the first update by running clean, then I had another 503 Error, but this time was an error page to see then that I could hammer out with the reindex. Thanks @ Rudi (which worked wonderfully via SSH) Now I miss only the table, can anyone tell me where and especially how the table has to be created? thanks – davefinitiv Jul 8 '15 at 21:51
  • I just looked up again exactly, the directory dev is available but it is above httpdocs :( how can something happen? Does it update via SSH better? If ever gone through with someone the update without errors? I use CentOS 6.6 with Plesk 12 and Atomic PHP 5.6.10 – davefinitiv Jul 8 '15 at 21:58
3

I am assuming you did the upgrade and got this error when you navigate through your frontend?

(This also happened to me)

I reindexed all from SSH command line.

Navigate to your /shell directory and execute:

php indexer.php --reindexall

Flush the cache and all should work !

  • I'll try it again, I had it now first return to 1.9.1, I had just seen that I indeed switched off during the update the cache but not atte external Zendcache, perhaps it could also be due? – davefinitiv Jul 8 '15 at 20:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.