2

I'm trying to call "login" method via SoapUI in Magento 1.9.1 and returns "Read Timeout".

Accessing the WSDL on browser and creating the project on the SoapUI works fine, but when i call any method PHP returns the following error:

6381  [Wed Jul 08 00:18:00 2015] [error] [client 189.114.159.156] PHP Warning:  SoapServer::SoapServer(http://{host}/index.php/api/v2_soap/index/?wsdl=1): failed to open stream: HTTP request failed!  in /var/www/html/mg_testeintegracao/lib/Zend/Soap/Server.php on line 814

6382  [Wed Jul 08 00:18:00 2015] [error] [client 189.114.159.156] PHP Warning:  SoapServer::SoapServer(): I/O warning : failed to load external entity "http://{host}/index.php/api/v2_soap/index/?wsdl=1" in /var/www/html/mg_testeintegracao/lib/Zend/Soap/Server.php on line 814

6383  [Wed Jul 08 00:18:00 2015] [error] [client 189.114.159.156] PHP Fatal error:  SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://{host}/index.php/api/v2_soap/index/?wsdl=1' : failed to load external entity "http://{host}/index.php/api/v2_soap/index/?wsdl=1"\n in /var/www/html/mg_testeintegracao/lib/Zend/Soap/Server.php on line 814

I've looked many posts about this problem and executed many possible answers:

Magento soap api login failed using PHP

SOAP API Call not working with Magento 1.9.1.0

SOAP API fails with "couldn't load from…", "failed to load external entity…"

Bug in CE version 1.9.0.1 connecting via Soap v1?

https://stackoverflow.com/questions/2976133/php-magento-soap-error-parsing-wsdl-couldnt-load-from-urlpath

I opened all ports on server and check php extensions like soap, xmlrpc, openssl, everyting is ok.

The 814 line of "/var/www/html/mg_testeintegracao/lib/Zend/Soap/Server.php" is:

$server  = new SoapServer($this->_wsdl, $options);

My server works with virtual hosts and the setting of this domain is as follows:

<VirtualHost *:80>
        ServerName {host}
        ServerAlias {host}
        DocumentRoot /var/www/html/mg_testeintegracao

    <Directory /var/www/html/mg_testeintegracao>
        Options Indexes FollowSymLinks
        AllowOverride All
    </Directory>

</VirtualHost>

Can it be a problem with that?

Someone has the same problem?

  • Is the server name used in the request URL available to the server as well as the client? Magento uses some loopback SOAP requests, so if it's not public, try putting it in the server's hosts file or public DNS. – Jim Lutz Jan 26 '17 at 17:57
  • Thanks for your attention, this problem is already solved – Lucas Keller Jan 27 '17 at 20:08
  • @lucaskeller how did you fix it? I am having exactly same issue. – Damodar Bashyal Sep 11 '17 at 1:47
  • @DamodarBashyal I can't remember, because it was a test project, probably I abandonned this at the time. Try reinstall all, because I have two Magento 1.9.3 running well the APIs nowadays – Lucas Keller Oct 20 '17 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.