1

Today Magento v. 1.9.2 released. It includes SUPEE-6285 Patch.

Upgrade from 1.9.1.1 went well without any issues, however the footer in admin area shows: Magento ver. 1.9.1.1

Does anybody else faced it?

  • Did you refresh the cache ? It's maybe just a display issue – AlternateChris Jul 7 '15 at 21:31
  • wierd question but, how can i upgrade it? – user27615 Jul 7 '15 at 22:14
  • If you have Magento 1.9.1.1 you can go to Magento Connect (if you have it enabled) and hit Check for Upgrades button, the click Apply Changes – Sharif Jul 8 '15 at 12:56
3

For some reason, the upgrade did not replace app/Mage.php which can be a typical result if you use Magento Connect to do the upgrade.

It probably failed to upgrade other module content as well.

The version number is found in app/Mage.php in public static function getVersionInfo() and if reviewing it shows 1.9.2.0 is the version number try recompiling and clearing cache to see if you get the number to increment.

Otherwise it's reinstall time via other means. This type of stuff is why I always do a manual install direct from the downloadable tar.gz file.

1

So I fixed it like this. Went to website root in SSH and did the following:

chmod +x mage
./mage mage-setup .
./mage config-set preferred_state stable
./mage sync
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
php shell/indexer.php reindexall

At step './mage mage-setup .' it thrown error "channel-add: Channel 'community' already exist!" which I think is ok.

After all I've logged to admin backend and it shows Magento v.1.9.2.0 now. Cleaned caches and once again did check for upgrades in Magento connect manager and it shows everything is up to date. Thanks

0

It is likely that if you upgraded via the Magento Connect system it has not fully upgraded some files.

The simplest way to ensure you system is fully upgraded is download the 1.9.2.0 update from here:

https://www.magentocommerce.com/download

Then extract all files and using FTP copy this to your Magento directory, overwriting all files. Then manually clear caches by deleting your var/cache folder.

0

Just to add, for me it was Zend's Opcache causing it to not fully upgrade. A simple php service restart fixed it.

protected by Community Jul 15 '15 at 12:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.