8

I have a new website that is running Magento 1.7.0.2.

When you search in the search bar for say "totem" nothing pulls up, instead it says no results can be found. I know there are results, but if you search specifically by the SKU like "tn truth-1" than a product will show up.

This was happening before I installed the search with the drop down.

Debugging Steps I have taken:

At this point I am not sure what else to do, I would love to give you code example, but I am afraid those won't help because there is no custom coding with the search, especially seeing that it didn't work when I put everything to stock Magento and no plugins.

If you need code or a stack trace, just let me know and I would be happy to get those to you if you tell me what files and how to make the stack trace since nothing is logging right now.

  • What are you searching for (keyword wise), and what attributes do you have setup to be included in the search index? – Axel Aug 29 '13 at 18:13
  • I am searching by like the product name. – Nick Darley Aug 29 '13 at 18:21
  • 1
    Look under Catalog > Attributes > Manage Attributes. Look for Name and post back what is says in the Searchable column. – Axel Aug 29 '13 at 18:35
  • Says Yes and it is set to Global – Nick Darley Aug 29 '13 at 18:57
10

With the help of @Axel I was able to fix the issue.

After digging into the Attributes and comparing the settings of the SKU since I could search by that and the settings of Name and Desc. I noticed a few differences.

here is what the SKU was set to

enter image description here

Here is what name was set to before I changed it

enter image description here

This is what I changed Name to

enter image description here

After that I re-indexed the site and then cleared the cache manually via ftp var/cache and deleted all folders in the cache then refreshed the site and tried to search and sure enough it works now.

Thank you Axel for pointing me in the right direction.

I also hope this helps anyone else having an issue with the search.

  • Glad you figured it out ;) – Axel Aug 29 '13 at 19:45

protected by Marius Nov 25 '15 at 13:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.