0

Hi I'm fairly new to Magento so this might be a stupid question.

I'm using default/carparts theme for my website. The problem is that the product reviews page is always blank like this:

enter image description here

Previous reviews and review form are not showing. I believe this is a bug of this theme because I tried other themes and this page all works well. Could somebody tell me what files should I check to fix this?

closed as off-topic by Rajeev K Tomy, liyakat, Mufaddal, Amit Bera, Fabian Blechschmidt Jul 1 '15 at 6:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about third-party modules are generally off-topic because the scope of functionality and code are not available. For more information, see this meta post/answer." – Rajeev K Tomy, liyakat, Mufaddal, Amit Bera, Fabian Blechschmidt
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Enable path hind and check all files are rendered – MeenakshiSundaram R Jun 30 '15 at 22:20
1

Replace default/carparts/layout/review.xml file. You can get fresh file from rwd/default/layout/review.xml

This file is responsible for your review.

Se section: <review_product_list translate="label">. Make sure this section exist in your review.xml file.

Please make backup of that file before replacing.

1

product/view.phtml was missing:

 <?php echo $this->getChildHtml('product_additional_data') ?>
1

Hi zxwang and welcome to MageOverflow. Unfortunately we can't help with all third party issues.You should read Fundamentals for debugging a Magento store and I recommend to set an exception breakpoint for xdebug. Often an exception is thrown which is then catched and ignored.

    try {
        $viewHelper->prepareAndRender($productId, $this, $params);
    } catch (Exception $e) {
        if ($e->getCode() == $viewHelper->ERR_NO_PRODUCT_LOADED) {
            if (isset($_GET['store'])  && !$this->getResponse()->isRedirect()) {
                $this->_redirect('');
            } elseif (!$this->getResponse()->isRedirect()) {
                $this->_forward('noRoute');
            }
        } else {
            Mage::logException($e);
            $this->_forward('noRoute');
        }
    }

This leads to an 404 status, but shows the page

Not the answer you're looking for? Browse other questions tagged or ask your own question.