1

I have a directory store in which magento files and folders reside. Therefore if I want to access the site, I need to specifically type the complete URL www.example.com/store to access.

I use avrixe hosting and have little idea about php stuff.

To counter the issue, I tried logging into cpanel and in website settings tried following
Folder in hosting Space - \expamle.com\www\store , This yielded 403 error. Please tell me how can this be achieved without fuss. Should I just chage the Redirect to URL in website settings to the complete URL

1 Answer 1

2

The 403 error might come from the redirection to http://www.example.com/store that Magento performs because this is the configured base URL. After you changed the directory from /www to /www/store, this URL does not work anymore and it shoul be http://www.example.com/

Steps to fix it:

  1. change the cpanel settings back to the path without "store"

  2. Go to Magento admin. System > Configuration > Web and remove "store/" from the base urls in the "Secure" and "Unsecure" sections.

    Do not remove the trailing slash, it should look likehttp(s)://www.example.com/

  3. Now change the directory in cpanel to the path with "store" again

5
  • after changing the setting to without "store" getting for 403 for mysite/store/ and 404 for mysite/store/index.php.... Jun 30, 2015 at 14:58
  • yes, this step was necessary to be able to access your admin panel again at example.com without /store Jun 30, 2015 at 14:59
  • right now i am not able to access anything. So it's not possible to do the second step Jun 30, 2015 at 15:03
  • if your cpanel settings are correct, cleaning the Magento cache might help (delete contents of store/var/cache). Also, clear your browser cache because browsers cache redirections. Jun 30, 2015 at 15:13
  • i am on aspnet hosting so had to do few extra things and now able to get the same working with the help of your method. thanks a ton Jun 30, 2015 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.