We use Paypal for all the payment options (customer is forwarded to the Paypal site to do a PayPal payment but stays within the shopping cart if paying by credit card /still settled by PayPal though/). I installed the Amasty's Delivery Date extension (basically a calendar) which appears on the Shipping step of the order /3 SHIPPING METHOD/ ( https://amasty.com/delivery-date.html )

I selected that customer MUST fill out the delivery date (it is mandatory). It works fine except for cases where customers pay with Paypal - then - it does not pass the delivery date back to the order in the Admin or the order Email.

**It works if the customer pays with a credit card (still processed by Paypal BUT I just noticed that when I click on option #1 (Debit or Credit Card) - it stays inside my shopping cart (the customer IS NOT forwarded to the Paypal site) - it just opens 4 rows:

>     > 1. Credit Card Type
>     > 2. Credit Card Number
>     > 3. Expiration Date 
>     > 4. Card Verification Number

So it must just be when the customer goes to the Paypal site!

Any ideas?

  • When you are testing paypal are you going to paypal from your checkout? or clicking "checkout with paypal" from the cart page or mini cart in the header? Jul 8 '15 at 22:02
  • in STEP 4 - PAYMENT INFORMATION - there are 3 options: 1. Debit or Credit Card 2. PayPal Credit and 3. Paypal (this is the one I think - when I click on it - it says: You will be redirected to the PayPal website. and takes you to: paypal.com/cgi-bin/…
    – Allysin
    Jul 8 '15 at 22:13
  • Ok. It is possible to skip the checkout page entirely by going direct to paypal, I thought that may have been what was happening. Jul 8 '15 at 22:17
  • How do I fix it?
    – Allysin
    Jul 8 '15 at 22:22
  • That sounds like a bug. You should contact Amasty. Jul 8 '15 at 22:26

This sounds like an issue where the session is not properly being carried through when users are redirected to/from the PayPal site.

Try adjusting your return URL in PayPal on the following page:


To this (assuming your using https):


Also ensure 'Use SSL Verification' is enabled in your Magento PayPal settings System->Configuration->Payment Methods (I'd suggest for both Payments Pro and Express).

Another setting to look at is your Session Cookie settings.

In System->Configuration->Web->Session Cookie Management set your Cookie Lifetime to 3600, your Cookie Path to / and ensure Use HTTP Only is set to No. You may also need to set your Cookie Domain to .yourdomain.com .

I'd suggest changing these settings for each store view/website scope.

  • 'Use SSL Verification' is enabled everywhere. The return URL within the Paypal settings was empty. I put what you suggested in there and ENABLED Auto-return - is this correct? Also - if we have 2 store fronts/domains - how is this handled? Thank you! :-)
    – Allysin
    Jul 9 '15 at 22:42
  • Yes, auto return should be enabled. For multiple stores magento should automatically redirect to the correct store. Jul 9 '15 at 22:45
  • Has that made any change? Also, sorry to be blindingly obvious but you'd need to replace yourdomain.com with the main site domain (the domain which you access the admin via) Jul 10 '15 at 9:20
  • Hi and thank you for trying to help! ;-) I did as you said (and YES - I changed yourdomain.com for the actual domain) and it did not work! Still have 2 orders (paid for with PayPal) from today with NO delivery dates..
    – Allysin
    Jul 11 '15 at 1:32
  • Any other ideas?
    – Allysin
    Jul 13 '15 at 15:24

we have heard from Amasty regarding their extension as we had a client using it. Amasty basically said that the extension doesn't support PayPal Express.

Magento 1.9.x PayPal integration will enable PayPal Express gateway even when using PayPal Standard.

So theoretically a solution would be to disable Express.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.