2

Magento CE 1.9.0.1 on dev environment running Ubuntu, Apache, PHP, MySQL - that's it.

Not a lot to this one: I'm trying to add some attributes to an input field within my CMS homepage. It's a single CMS page.

I try to change this:

<input class="form-control" type="text" />

To This:

<input class="form-control" placeholder="Enter your email address" type="text">

And it continuously reverts back to the first example. Sometimes it will save, allow me to refresh the page 2 or 3 times showing the second, correct version and then it will show me the first version again. I don't get it and I can't explain it. The CMS section is also stripping white space out of my CMS pages that I intentionally insert to make the code more readable but that isn't my primary concern right now. Has anyone seen behavior like this in a vanilla install of Magento on a minimal development environment (or otherwise)? Thanks.

1

I am running Magento 1.9.2.1.

Here is my experience with cms: I am trying to insert HTML and inline CSS. For example:

<div style="position: relative; left: 0px; top: 0px; width: 1200px; height: 450px; background-image: url('{{media url="myimages/asdf.jpg"}}');">

Please note: I can get my code to appear properly on the front-end. But when I hit save, my CMS code changes and it is not being rendered properly in the admin pages HTML editor! Here is what I see when I go back:

<div style="position: relative; left: 0px; top: 0px; width: 1200px; height: 450px; background-image: url('{{media url=;">

In addition, Magento likes to make other types of changes for me. For example, if I insert a CMS tag

{{media url=...}}

I might all of a sudden find it is surrounded with:

<p>{{media url=...}}</p>

Please stop changing my code! How to disable/fix?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.