2

This is a weird situation, Magento stopped sending New Order emails, contact form submission etc. Interesting, after a customer places and order, I can go in and click send email and the email will be sent.

I am using Ashroeder SMTP Pro, and it is passing the test, I have been using it for about a year now, the only thing I can think of I changed recently is that I shortened my Order numbers from 9 digits to 4 digits.

I have googled this all day and tried a bunch of different things without success. I think that the function to send email is not being called automatically. No error message as far as I an tell.If anyone will be kind to point me in the right direction that would be appreciated.

  • I pinged Aschroder himself. Let's see if he can help you. Did you try contacting him for support? – philwinkle Aug 27 '13 at 23:16
  • Thanks, I did not contact him, I was thinking I ruled out his extension as being the problem since the self test passes and I can manually send email but not automatically. – Val Okafor Aug 27 '13 at 23:20
  • Have you confirmed that the emails are still enabled in System > Configuration > Sales > Sales Emails? – Roscius Aug 28 '13 at 2:57
6

The fact that any emails can send at all is a good sign, but it would be worth checking they are sending as expected. Enable logging (system->config->developer menu) and check the log output after these operations:

  1. SMTP Pro self test
  2. manually sending an email via admin
  3. contact form submission
  4. placing a new order

1) and 2) should show SMTP related output. If they don't then it means that although SMTP Pro is installed, something else (another extension, code modification) is interfering with email sending.

If 3) and 4) show SMTP Pro output then it's a weird situation where SMTP Pro works for some emails but not all - I'm reasonably confident that won't be the case here - if it is send me more details.

At this stage it'd also be good to check the exception logs in Magento, and the Apache logs to make sure some error is not occurring when you tested 1-4.

At this point you're going to need to step through either the contact form or new order process and see why it's not sending emails - if you have a debugger, use that. Otherwise, get busy with Mage::log() in the Contact Form code - start with the controller Mage_Contacts_IndexController.

As @Roscius pointed out, order emails not sending could be caused by configuration, so I'd suggest focus on contact form first, it's an easier module to debug through.

It's entirely possible it's two different issues though, as there's not a lot of overlap between the contact form sending, and the new order email sending.

If you update your questions with more info from the above debugging steps, it will help diagnose the issue further.

  • Thanks, I added another store and apparently the main store was inheriting the wrong settings, so I changed to the main store view and set Disable Email Communications to No under Send Email Settings. I did not want to bother you so thanks so much for chiming, I have two other sites where the SMTP Pro is working like a charm and I am planning another site where I plan to use your new Amazon Extension – Val Okafor Aug 29 '13 at 19:27
1

Ok, I think I have the same problem and I traced it...

I'm using Magento CE 1.8 and installed the Ashroeder SMTP Pro. It worked when I set to use Google Apps/Gmail, but didn't works when I set to use the SMTP of my domain. Any error was reported in any log, just reported as "Test email was sent successfully" but any email was delivered (I checked the spam inbox). The domains SMTP was working (tested with a e-mail client software).

In my case, to solve the problem, I did't added any other store. I just changed the "Store mails" in system->config->store mails to the same domain. There were set e-mails from another domain (gmail.com) and I think this was the reason my SMTP domain was rejecting. In my case it MUST be the same "@domain.com" as the SMTP server to work. Otherwise the e-mails are rejected by the SMTP server. This is not a problem with magento or Ashroeder SMTP Pro.

Ashley Schroder thanks for your work. Please update it with this information!

0

I fixed the problem by switching the view to the appropriate view in the back end. I had added another store and the main store was inheriting the wrong settings, so I changed to the main store view and set Disable Email Communications to No under Send Email Settings.

It is working fine now.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.