2

I have recently started experiencing issues when saving or running any dataflow profiles in Magento. When trying to do so I get the following error message:

Please set available and/or protected paths list(s) before validation.

After reviewing the code I came across the following inside the Mage_ImportExport_Helper_Data class on or around line 57:

public function getLocalValidPaths()
{
    $paths = Mage::getStoreConfig('general/file/importexport_local_valid_paths');
    return $paths;
}

This function is setting the returning a list of paths that are allowed to be inputted. The variable being returned is null everytime even though the following is set in the Mage_ImportExport extensions config.xml file:

<default>
    <general>
        <file>
            <importexport_local_valid_paths>
                <available>
                    <export_xml>var/export/*/*.xml</export_xml>
                    <export_csv>var/export/*/*.csv</export_csv>
                    <import_xml>var/import/*/*.xml</import_xml>
                    <import_csv>var/import/*/*.csv</import_csv>
                </available>
            </importexport_local_valid_paths>
            <bunch_size>100</bunch_size>
        </file>
    </general>
</default>

Has anyone experienced this issue before and know how it can be resolved?

2

There is no system.xml in Mage_ImportExport, therefore you can not edit this setting in the backend.

You might still want to check core_config_data, just in case some data or install script did something with this setting. The path should be general/file/importexport_local_valid_paths (/available?) So just search for LIKE %general/file/importexport_local_valid_paths%

And the last idea I have is, that for some reason, you overwrite this setting in some other config.xml or app/etc/local.xml

  • Hi Fabian, Thanks for your reply. What setting should I be looking for in particular inside the core_config_data table? – Ryan Copeland Jun 29 '15 at 8:47
  • edited the answer to add this info :) – Fabian Blechschmidt Jun 29 '15 at 9:31
  • Thanks Fabian. The row was missing from the table so must have been removed in the past some how. Thanks again for your help. – Ryan Copeland Jun 29 '15 at 12:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.