0

I'm currently setting up a Magento install with two websites, one called wholesale with a store view of bsc, and one called general with a store view of bombmtl

I've configured both to use https regardless of context, and yet for some reason, while https works fine for the wholesale website, if you go to https for the general store it redirects back to non https - the site displays fine, so it's all working, but it's refusing to load on https.

I've rechecked my Web config, and everything looks right to me:

Default: - Add Store Code to URLs: No - Base URL: https://wholesalestoredomain.com - Base URL (Secure): https://wholesalestoredomain.com

(The wholesale website then uses 'Use Default' for everything).

General Website: - Base Url: https://generaldomain.com - Base Url (secure): https://generaldomain.com

As I mentioned above, the wholesale website works fine, but if you go to https://generaldomain.com, it then redirects to http://generaldomain.com - it shows the correct (ie. Non default) website, so it's getting the right store code, but it's redirecting back to http even through the settings are 100% for it not to.

I can also confirm it's being caused by Magento - if I put a die() call in index.php right before Mage::run, then it stays on https and shows whatever message I've put in the die statement, so it's not that the server (or htaccess etc) is causing it.

I've cleared the cache and re-indexed (going so far as manually deleting all the cache files via SSH and using the shell/indexer.php to reindex), and I'm still not getting a positive result.

Hopefully someone can give me some idea of where to look next!!

0

At what scope are you setting the URLs for your second domain? If it's at website, make sure its not overridden again at the store scope.

  • andrewkett the scope is website, and the store view inherits that. – Liam Wiltshire Jun 22 '15 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.