2

I have an issue when I try to upload a new picture. I upload the new picture then select Thumbnail, Small image, Base Image for this mew picture. Then I select Remove for the old picture. Then I click on Save. I clear cache and storage. On the website I still have the old picture. In the backend, in manage product:

  • the new picture is uploaded the old picture is defined as excluded (where as I had selected remove) - I can't change "1" in sort order.
  • the new picture is enabled for thumbnail, small image and base image - sort order is 1

To prevent some problem, I have uploaded the latest version of flash and tried to do the operation through 3 different browser.

Anyway, I can't upload new picture. Please help me to fix.

  • You could try: right click on the image on the frontend, view page source, find the location on the server of the old image, delete it from the server, refresh all caches again, including Catalog Images Cache – Michael Jun 22 '15 at 10:01
  • Otherwise check media permissions, check media folder for the new images, check php's memory limit, check the specific store view. – Michael Jun 22 '15 at 10:01
  • After inspecting element i've noticed thaht picture is not located on my server but on a CDN. How should I modify picture now ?cdn.delishop.co.th/home/media/catalog/product/cache/.../… – Eric Ly Jun 22 '15 at 10:54
  • It seems like CDN has nothinf to matter with my photo uploading problem, Please Kaska can you tell me how to check media permissions and check Php memory limit ? – Eric Ly Jun 22 '15 at 11:10
  • It probably isn't due to this, but you can run sudo chmod -R 777 media/ in your magento root directory. In your .htaccess file you can find the line php_value memory_limit 256M (should be at least 256M), you could also try refreshing your browser cache too. Apart from that I'm not sure. – Michael Jun 22 '15 at 11:24
0

OMG. do you understand that your CDN is a waste of money?? you have local shop, in Thailand, why the heck you need your media to trip around the world??

look at the network https://cdnify.com/network
this CDN is not even for APAC region...

your CDN is probably caching images for 3 months,

Cache-Control:max-age=7776000
Connection:keep-alive
Content-Encoding:gzip
Content-Type:image/png
Date:Mon, 22 Jun 2015 11:35:33 GMT
Expires:Sun, 20 Sep 2015 11:22:58 GMT
Last-Modified:Tue, 19 May 2015 08:02:27 GMT
Server:Cdnify
Server:nginx
Transfer-Encoding:chunked
X-Cached:HIT
X-Server-Name:london2.a.cdnify.net

you need to login to your CDN control panel and purge those images, or send command from the server to their API
https://cdnify.com/learn/api

Purge Cache

Purge the cache of a resource by its ID. Successful cache purges will not have a response body.

DELETE https://cdnify.com/api/v1/resources/{resource_id}/cache
Parameters

Name    Type    Required    Description
files   array   no  An array of filenames; e.g. ['/js/jquery.js']
If the files parameter is not specified, then all assets will be purged.

Status codes

Code    Description
204 The cache was purged
400 Something went wrong
429 Rate limit reached
  • Thank you for your answer. Since we have this CDN it seems like our website is loaded more faster. (-3 sec for the home page). I'll try to purge CDN Cache in order to upload new picture. – Eric Ly Jun 23 '15 at 2:00
  • I have purged it, but it still can't upload new picture... – Eric Ly Jun 23 '15 at 3:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.