3

I have an install where multiple stores are being used and some products are common across all stores.

The issue is with one of the store, the url http://domain.lo/store2/checkout/cart/add?product=327&qty=1 doesn't add the product to cart but session message does show up on cart page saying product was successfully added. I tried to use a debugger but didn't find anything wrong in the execution flow, it works correctly as far as I can tell.

The product is definitely in stock and works fine on main & other stores. Even its product page loads fine directly but that doesn't load on store2, one in which I have the problem. So, I reindexed everything but still no luck.

Out of ideas how to troubleshoot it further. Any pointers?

  • do you get anything logged in var/log? – Marius Aug 26 '13 at 16:59
  • @Marius Nope, nothing! Even with jumping through a debugger, I didn't find anything wrong. – Ashfame Aug 26 '13 at 17:40
  • try this: magento.stackexchange.com/questions/428/… – Marius Aug 26 '13 at 17:58
  • @Marius Tried with developer mode, error logs & moving out community & local modules, didn't help. – Ashfame Aug 27 '13 at 10:24
  • Is your other store on domain.lo - if yes do you have an active session (frontend cookie) from this store. Also does it work when using the uenc version of the add to cart link (like /checkout/cart/add/uenc/XYZ...) ? – Kristof at Fooman Aug 31 '13 at 20:34
1

I recreated the products from fresh and that made it work, looks like it was a hiccup with how a few products were saved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.