1

Currently I have downloaded magento on my system. After that I just uploaded that file to my server(in zip format). After upload I went to the server and extracted all the files from folder. Now as I want to install magento I browsed through my site url demo.sitename/magento/index.php it made one redirection for installation demo.siteurl/magento/index.php/install/ with one error like

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

This came for there is no folder called install but one file is available and that is called as install.php. Now I again browsed the page as demo.siteurl/magento/index.php/install. This time it showed me the Magento's Installation Wizard! Now after clicking on checkbox I agree to the above terms and conditions. and click on submit it again redirected me to the page http://demo.sitename/magento/Index.php/install/wizard/beginPost/ . After this it is again showing ` 404 - File or directory not found. The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I have gone through many forums and blogs but did not found any solution. Below this I am attaching my.htaccess` file details

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    php_value memory_limit 256M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## uncomment next line to enable light API calls processing

#    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

############################################
## rewrite API2 calls to api.php (by now it is REST only)

    RewriteRule ^api/rest api.php?type=rest [QSA,L]

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## always send 404 on missing files in these folders

    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l


############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    Order allow,deny
    Allow from all

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

    <Files RELEASE_NOTES.txt>
        order allow,deny
        deny from all
    </Files>

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

Someone kindly tell me why this is error is happening? Any help and suggestions wil be really apprecaible. Thanks..

Edit

here is the server info

Cache-Control no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Content-Encoding gzip Content-Length 6789 Content-Type text/html; charset=UTF-8 Date Sat, 24 Aug 2013 12:15:29 GMT Expires Thu, 19 Nov 1981 08:52:00 GMT Pragma no-cache Server Microsoft-IIS/7.5 Set-Cookie PHPSESSID=sotdvdsaqva9345igtt37sqvr2a5; expires=Sat, 24-Aug-2013 13:15:30 GMT; path=/magento; domain=demo.linkurl.info; httponly Vary Accept-Encoding X-Powered-By ASP.NET X-Powered-By-Plesk PleskWin

  • firstly the url looks wrong. Index.php should be index.php (if the server is linux based) which leads to my questions, as you need to supply some more info: What type of OS is server, what webserver is used (apache as an example) and is url rewrites enabled (mod_rewrite if apache) Does your environment meet the requirements? magentocommerce.com/system-requirements – ProxiBlue Aug 24 '13 at 12:12
1

You are running the Microsoft IIS webserver, as IIS doesn't work with the .htaccess you need to active the url redirect to get it working, to do this open (or create) the web.config file in you webdirectory and insert this:

<rewrite> 
<rules> 
<rule name="Imported Rule 1” stopProcessing="true"> 
<match url=".*" ignoreCase="false" /> 
<conditions> 
<add input="{URL}" pattern="^/(media|skin|js)/" ignoreCase="false" negate="true" /> 
<add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" /> 
<add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" /> 
</conditions> 
<action type="Rewrite\" url="index.php" /> 
</rule> 
</rules> 
</rewrite>

I never tried using Magento with the IIS webserver, so maybe it is a better solution to use the Apache server on your windows machine, this way you can use the .htaccess files that comes with Magento.

1

as per my comments on OP question, regarding magento server requirements, IIS is not supported. As suggested, install apache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.