I'm having an issue getting a custom module's menu item to show. Normally it is set to appear to the right of the System menu item in the dashboard however it is acting abnormally.

Scenario A:

I do a clean install of CE, then install the custom module and it works perfectly. Shows as intended.

Scenario B:

I attempt to install this custom module onto the client's production website and it refuses to show. I've verified that it is registered and enabled under System > Configuration > Advanced > Advanced. I've tried clearing every type of cache both manually and through the admin panel, I've reindexed, logged out and back in dozens of times, checked error and system logs along the way and still nothing.

My assumption is that something else on the client's site has a duplicate naming convention or similar that is overwriting my custom's modules menu item presence as it works perfectly on other sites of same version.

How would I proceed with debugging? Should I be putting logging commands somewhere in my modules controllers? Is there a better way?

Thanks in advance.

  • Check with the acl Jun 14, 2015 at 10:01
  • Did you figure out the issue? I am having same issue. Gift cards menu is hidden since upgrade to enterprise Feb 20, 2017 at 23:27

2 Answers 2


As my experience with admin menu, they are mentioned wether in etc/adminhtml.xml or in etc/config.xml file.

The menu can be set in these file to be available only if module is enabled like this:

        <mycustom_menu translate="title" module="[module_name]">
            <title>My Custom Menu Item</title>
                <!-- child items go here -->
                <subitem translate="title" module="[module_name]">

So in this case, if payment > checkmo is active then this menu will be displayed.

Check if that's the case.


Check your system.xml file specifically the section and group nodes, try renaming them for debugging purposes, check that the xml validates, turn on logging and check for xml parsing errors

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.