1

The problem I am having is that my site is slow after you import my products with magmi

http://fpm5.5-check.cluster015.ovh.net/phpinfo.php

After searching the memory of my php of origin here is what I find the memory_limit is has 512 but why the homepage of my site is also slow?

1

PHP's memory_limit setting should have no effect on Magento's performance. It only sets the high threshold of memory usage by PHP processes, and if Magento hogs more memory than that limit, you will get errors, but it changing it won't make things faster.

I would strongly advice against modifying memory_limit to anything other than the recommended value unless you know what you're doing. Setting it too low may cause some of your Magento pages to crash, and setting it too high might cause your entire server to slow down to a halt in extreme cases.

Instead, I would advise searching the Web on some tips on how to optimize Magento's performance. There are many relevant posts that can point you in the right direction. This post on my company's blog is one example, but there are many others. Enabling various forms of caching, using a CDN and optimizing your DB settings are probably the first places you want to look into.

BTW, I would also strongly advise against posting your server's phpinfo() output publicly for security reasons. You should remember to delete that file as soon as you can.

0

You can change the memory limit globally in php.ini, look for this line:

memory_limit =

and adjust the value acording to your needs, also you can do it in line in any given file you want like this:

ini_set("memory_limit","1G");
  • In what file I have to change cela? In my .htacces Magento or server? – webevolution Jun 13 '15 at 19:16
  • php.ini is located in your server, the path to your file depends on the server, normal places are: /etc/php5/apache2/php.ini, /etc/php5/fpm/php.ini, etc. If you can't modify your php.ini then just use ini_set instead, add that line after the <?php to any file, for instance index.php. This should a temporary solution for testing, is always better to do this on the php.ini – lloiacono Jun 13 '15 at 19:26
  • How to access to this kind of file? – webevolution Jun 13 '15 at 19:31
  • If you don't know then is very unlikely that I can help you. Ask to your hosting company for access or to change the memory_limit themselves – lloiacono Jun 13 '15 at 19:33
  • OK I would ask Monday. – webevolution Jun 13 '15 at 19:34
0

You will try with magento cache extensions. There are lot of magento extension available in Magento connect.

In magento, by default its has cache managment in admin. I hope you enable the cache in magento admin.

Please refer this link below, it will help you

https://stackoverflow.com/questions/1403184/what-are-the-best-steps-to-improve-magento-performance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.