6

I can't seem to see any of the upload of browse image buttons on my magento backend, I have tried Firefox and chrome with no luck. I get these errors in Firefox inspect element:

TypeError: flashPlugin is undefined flex.js:164:7 ReferenceError: id_a13736761dc61600b7a42cbca740d27f_UploaderJsObject is not defined

I found out that I should check these files exist but annoying they found.

/skin/adminhtml/default/default/media/uploader.swf
/skin/adminhtml/default/default/media/uploaderSingle.swf
/skin/adminhtml/default/default/media/editor.swf
/skin/adminhtml/default/default/media/flex.swf
/app/design/adminhtml/default/default/template/media/uploader.phtml
/app/design/adminhtml/default/default/template/media/editor.phtml

any other suggestions what could be the problem?

4

I wasn't able to view the buttons last week. It was because Flash hadn't been updated. So I suggest you make sure Flash is up-to-date first.

Other suggestions:

You could try restarting the browser

Or in the php.ini file change upload_max_filesize = 100 M to upload_max_filesize = 100M, (no space) or

Check if .gitignore is referencing media/ instead of /media/ or

Copy /app/design/adminhtml/default/default/template/dull from a fresh copy of magento

  • Just downloaded and uploaded newest flash but still not there :( – Adam Allen Jun 10 '15 at 15:55
  • I've edited my answer. – Michael Jun 10 '15 at 17:22
  • updating flash player fixed for me +1 – Tahir Yasin Jul 1 '15 at 7:46
2

That problem come up to me after Chrome update (Version 59). To solve this I just click in Always allow on this site in Flash permissions.

Or enable Flash folloing this link

0

I would say, that this code:

var version = false;
if (navigator.plugins != null && navigator.plugins.length > 0) {
   if (navigator.mimeTypes && navigator.mimeTypes.length > 0) {
      if (navigator.mimeTypes['application/x-shockwave-flash'] &&
          !navigator.mimeTypes['application/x-shockwave-flash'].enabledPlugin) {
         return false;
      }
   }
   var flashPlugin = navigator.plugins['Shockwave Flash'] || navigator.plugins['Shockwave Flash 2.0'];
   version = Flex.transformVersionToArray(flashPlugin.description);
} else {
   version = Flex.transformVersionToArray(Flex._getFlashPlayerVersionAsActiveX());
}

only defines flashPlugin, when you have flash installed. Therefore is my conclusion: You don't have flash installed.

  • When i go onto flash donwload on chrome it says this "Your Google Chrome browser already includes Adobe® Flash® Player built-in. Google Chrome will automatically update when new versions of Flash Player are available." – Adam Allen Jun 10 '15 at 15:44
  • Keep in mind that you may have Flash installed, but for whatever reason (browser settings, installed browser extensions, etc) Flash is not being loaded. In Chrome, if you see a small puzzle piece icon on the right side of the omnibar, click it and choose "run all plugins". If this is the case you've got something disabling Flash. – pspahn Jun 10 '15 at 19:25
0

In my case, I fixed the issue by downloading the latest Adobe Flash Player

in the magento uploader.phtml file it says this:

<?php echo Mage::helper('media')->__('This content requires last version of Adobe Flash Player. <a href="%s">Get Flash</a>', 'http://www.adobe.com/go/getflash/') ?>

I did that & the problem went away

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.