0

I just started adding products to a new magento setup. The theme pages are all loading quickly. However the first category that I started to add products to is quite slow to load the first byte.

You can see that here: http://gostwear.nextmp.net/english/coveralls-overalls.html

there are only 4 configurable SKUs on there right now. though the total amount of SKUs for each is quote large (about 300 SKUs for one of those configurable products).

I am not sure if it is because of how many SKUs there are or something else. The rest of the pages seem to load quickly. And it mostly seems to be waiting for that first byte to load.

Any help is appreciated!

  • ive seen this problem with colorswatches, you need to run Aoe_Profiler. or at least disable colorswatches to debug. – user2857 Jun 10 '15 at 15:26
  • Disabling colorswatches fixed made a tremendous difference.. Now what can I do.. – Sackling Jun 11 '15 at 15:19
  • now you disable CS for category pages, and look for a patch that will fix this bug. :) someone was already trying to fix it, use search. – user2857 Jun 11 '15 at 15:49
  • The only way I see to disable it through admin, is by editing the attributes and setting the "use in layered navigation" to no. But then I won't even see the list of attributes to sort, or is there another way? Is this the post you are referring to? magento.stackexchange.com/questions/49927/… – Sackling Jun 11 '15 at 16:55
  • After reading the wigman post about his plugin, it sounds like it will really help/solve the issue I am having. I am new to magento but I know it has been around a while already. I find it strange that a product swatch would have such a tremendously negative impact on load time for something that seems somewhat standard on e-com shops these days. On the other hand a fix does seem to exist.. So maybe I'm just being a baby. – Sackling Jun 11 '15 at 17:04
1

Since you posted the answer in a comment there's no answer you can accept as a solution, so I'm putting it here so you can upvote me for creating the extension that solved your problem: https://github.com/wigman/AjaxSwatches/.

Fair enough?

0

i dont really know if the number of (sub) sku's is related to load time. i think this is a tipically element to be cached.

i alwayss use ssd-servers to host magento shops. i never had a similar problem.

database-size in general is a problem to magento. that is one reason why i advise ssd to every magento shop. how many (simple) products and how many store-views do you have?

0

There are so many reasons a catalog page could be slow. It could be server setup not making full use of the resources, maybe a third party extension listening to an event which is doing something inefficiently, a theming issue, thats just a few of the possible scenarios.

That said as you have mentioned colour swatches. I recently had a performance issue with magentos native colour swatches when using the (color)-swatch label pattern as the means of setting the swatch image on a configurable product. I tracked it down to the Mage_ConfigurableSwatches_Helper_Mediafallback::attachConfigurableProductChildrenAttributeMapping function. Its the same issue documented on this SE question.

Moving the array_map code out of the foreach loops I was able to reduce our page load time from 1:30 to around 10 seconds (small server, many products and attributes). Rather than change the core file as suggested in the linked answer I would recommend overriding the method in your local namespace.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.