4

I did enabled the profiler at System->Configuration->Developer->Debug->Profiler and I commented out the line Varien_Profiler::enable(); inside the index.php file.

But when I refresh the page, the table at the bottom is displayed empty.
How can I fix this?

3

You need to enable the profiler output from System->Configuration->Developer->Debug->Profiler

6
  • I did enable Profiler function in System->Configuration->Developer->Debug->Profiler
    – JGeer
    Jun 8 '15 at 13:17
  • 1
    Check if it's disabled in store view scope.
    – Marius
    Jun 8 '15 at 13:18
  • Nope it is not, all are set to use default config. And I did changed it in default config. I only see empty tables right now.
    – JGeer
    Jun 8 '15 at 13:19
  • What magento version are you using?
    – Marius
    Jun 8 '15 at 13:20
  • 1
    How is this the answer if you already did this? im confused Jul 12 '17 at 12:56
13

Go to your /index.php and search for

Varien_Profiler::enable();

In your case the line should be commented. Uncomment it and you should see the profiler's contents.

1
  • 3
    This post should be answer to the question ... Oct 14 '16 at 11:55
6

If you want to enable profiler, Here is the way

  1. Admin Dashboard >> System >> Configuration >> Developer >> Debug >> Profiler

  2. Open “index.php” file located at the MAGENTO_ROOT folder in editor and find the link of code #Varien_Profiler::enable();. Uncomment this line and save like below

    require_once $mageFilename;
    
    Varien_Profiler::enable();
    
    if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
      Mage::setIsDeveloperMode(true);
    }
    

Thats all, profiler has been enabled.

enter image description here

If you want to enable sql profiler, Here is the way

To enable sql profiling,

  1. you need to enable “Profiler” from admin
  2. Open the local.xml config file located in /app/etc/ folder and add the node <profiler>true</profiler>

Example :

<resources>
 <db>
  <table_prefix><![CDATA[]]></table_prefix>
 </db>
 <default_setup>
  <connection>
   <host><![CDATA[localhost]]></host>
   <username><![CDATA[root]]></username>
   <password><![CDATA[]]></password>
   <dbname><![CDATA[magento_1_8_1_0]]></dbname>
   <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
   <model><![CDATA[mysql4]]></model>
   <type><![CDATA[pdo_mysql]]></type>
   <pdoType><![CDATA[]]></pdoType>
   <active>1</active>
   <profiler>true</profiler>
  </connection>
 </default_setup>
</resources>

save the file and clear the cache.

enter image description here

2
  • sadly i have done all this and i still get no profiler data showing up on the frontend :\ Jul 12 '17 at 13:01
  • If i enable profile all the customers able to see the profiler right? how to enable profiler only for admin?@zed Blackbeard
    – zus
    Feb 26 '19 at 6:45
2

If you're working with a multilanguage Magento istallation or if you installed it in a subfolder make sure you've also uncommented

Varien_Profiler::enable();

in the subfolder's index.php

otherwise you'll see an empty table when visiting that subfolder (i.e. www.mysite.com/en/)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.