1

For some reason my Magento shop always redirect to https. I set config -> web -> unsecure -> base url to http://, so that can not be the problem. Changed also store view to check all views.

And htaccess is also not redirecting to https.

But I do not know where in my code the site is redirecting to https. I already changed to the default Magento theme, but still the website is redirecting to https.

Maybe I edit a core file a time ago, but I do not know what file it can be.

Is there a way to find the location of this problem?

  • Please check storewise configuarion.. goto system>Configuration> on the left panel chnage the scope – Amit Bera Jun 8 '15 at 11:30
  • @AmitBera Checked this also, but still redirecting. In what core files can this be managed? Maybe I changed something there a time ago..!? – Henk Z Jun 8 '15 at 11:41
1
  1. If it is the core, grep for https.

  2. If it is the database search for https.

Make sure your cache is up to date, so it is no old setting.

You can put a die() in the first line of your index.php to make sure it is not your apache/nginx

  • Thanks, but how can I search inside files on server by using FTP? Because I can only search for filenames and filedate etc. Not inside a file. – Henk Z Jun 8 '15 at 12:24
  • You can't afaik. You SSH. If you don't have SSH think about downloading everything and search then. And yes, what you learn from it: Have a hoster which allows SSH. – Fabian Blechschmidt Jun 8 '15 at 12:37
0

this is because you have installed extension that overwrites your frontend secure url, it sets all shop to https in config.xml

<secure_url>
          ...
        </secure_url>
    </frontend>
  • Can this only be defined in the folder app/code/ ? Or also inside the folder app/design/? – Henk Z Jun 16 '15 at 7:38
  • app/code/ look for new extensions – user2857 Jun 16 '15 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.