0

When I make a configurable product, I would like the default selection on the drop-down to be "Choose an Option..." (as apparently it should be).

For example, for a product I have:

Choose an Option... Yes, add accessory +$9.99 No, do not add accessory

When I view the product on the frontend, the default selection is "Yes, add accessory +$9.99" instead of "Choose an Option..." like it should be and thus makes the default price $9.99 higher than it should be.

How do I fix this? I suppose I could make simple products and just add these options as Custom Options, but it will not track inventory if I do it that way.

  • you need to select the default option as "Choose an Option"? – saravanavelu Jun 8 '15 at 4:22
  • There is no option for that. By default, magento is supposed to make that the default option but it's not – JoeyD0831 Jun 8 '15 at 5:55
1

I think you have once set one of the associate product to default. Since that section is radio button you cannot undo this.

But you can get way around to it. You simply need to perform following task step by step:

Simply uncheck that selected product in Associate product list and check again & hit save.

If this doesn't help follow following steps:

  1. Uncheck that product (chosen to be default) from associate product list and save that config-product (please take note of this product's id, you will need later)
  2. Now, go to Associate Product section and search & choose that product (the one you unchecked in step-1)
  3. This time do not choose any item to be Default and simply save the config-product.

Hope this will do what you intend to.

Update

To remove any extension you can do two way:

  1. Go to Magento Connect Manager and uninstall it from there (if you have installed the extension through this)
  2. Or just go to app/etc/modules/Easylife_Switcher.xml and set <active> to false OR even delete this file along with app/code/community/Easylife/Switcher folders and it's belonging files in design folder.

I believe this extension has update some other as well, so if removing this doesn't work then you should reinstall fresh magento.

| improve this answer | |
  • None of the associate products are set as default. Magento is picking the first associate product (based on ID) and making it default on the frontend – JoeyD0831 Jun 8 '15 at 17:56
  • Do you have any jquery/javascript for this? Or else, I doubt you have customized core files: php/phtml. – Adarsh Khatri Jun 9 '15 at 0:00
  • No I have not changed any of the core files of magento – JoeyD0831 Jun 9 '15 at 6:44
  • Can you add your screenshot of associated product section. – Adarsh Khatri Jun 9 '15 at 6:46
  • imgur.com/8NsBrHh – JoeyD0831 Jun 9 '15 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.