0

After upgrading to PHP 5.4.28, Magento Connect Downloader is broken. The iframe downloader won't work. Screenshot below. Disabling php-fpm gzip compression allows Magento Connect Downloader to work normally.

Isn't the php-fpm gzip compression extension needed by Magento? How can this be fixed correctly?

UPDATE: Tried on PHP 5.5 with fresh Magento install. The issue persists.

Magento Connect Downloader not showing the iframe downloader.

  • keep gzip enabled in server config, and disable compression in php.ini – user2857 Jun 7 '15 at 8:06
  • Won't php.ini be overwritten when Magento is updated? – Joel Karunungan Jun 7 '15 at 12:18
  • no, i dont think that magento have any php.ini files enabled/active – user2857 Jun 7 '15 at 21:30
  • Yes, I just checked. It only has a sample php.ini file. Would you know if PHP zlib.output_compression is needed by Magento to run correctly? I'm not really sure, if it might be needed by some function, etc. – Joel Karunungan Jun 7 '15 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.