I'd like to ask what magento version is it better to develop a module for so that it would be compatible with most versions.

Any professional opinion?



This really depends on what your plugin does.
I'm sure that there are plugins for 1.0 that work on 1.9.
But you have the highest chance starting at 1.7.
I say this from experience.
All my extensions support the 1.7 version and most of them work out of the box or with minor chances on higher versions.

  • Thank you a lot Marius! Nice answer! In what case would developping a module for 1.8 or 1.9 mean that it won't work on 1.7? Thanks! – Supersonic Jun 6 '15 at 21:13
  • There are various things.Usually the things that changed between those versions may make an extension incompatible with at least one of the versions. One example could be the checkout. Each step of the onepage checkout requires a form_key in version 1.8, but it doesn't require it in 1.7. – Marius Jun 7 '15 at 12:02
  • Are there many such situations? Could you give a few more? Thanks! – Supersonic Jun 7 '15 at 12:36
  • Check the release notes for 1.8 and 1.9. Anything in there might prevent your extension from working on different versions. devdocs.magento.com/guides/m1x/ce18-ee113/… devdocs.magento.com/guides/m1x/ce19-ee114/… – Marius Jun 7 '15 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.