1

When I log into the backend and navigate to Catalogue > Manage Product everything is working fine. When I click on a product I get a blank page, with a link to 'Create new video' and 'Add an attribute'.

Our setup is: ubuntu 12.04, nginx php5-fpm and varnish.

My nginx log is displaying this error:

*6711 FastCGI sent in stderr: "PHP message: PHP Fatal error: Call to a member function __toString() on a non-object in /var/www/clients/client1/web2/web/app/Mage.php on line 859" while reading response header from upstream, client: 82.71.243.141, server: www.example.com, request: "GET /index.php/admin/catalog_product/edit/id/801/key/918d6b60004194117d8783613d066922/ HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web2.sock:", host: "www.example.com", referrer: "https://www.example.com/index.php/admin/catalog_product/index/key/bcc1f51a9f74e1f425be8d93903f0949/"

Can anyone help with problem as I'm really stuck?

1

This problem appears when logging is done in wrong way.

Mage::logException("logging message");

This line will produce

( ! ) Fatal error: Call to a member function __toString() on string in /var/www/monoqi_b2c/app/Mage.php on line 858

Probably you have some custom extension that does not process Exceptions properly.

Something is wrong with yours php error reporting, because php should report that method logException gets wrong type variable.

Update

Tried to reproduce on php cli and mod apache and I've got

Catchable fatal error: Argument 1 passed to Mage::logException() must be an instance of Exception, string is given

Yours php Fast CGI does not support Type Hinting.

  • Thank you. I'm investigation your suggestion and will let you know – artworker Jun 4 '15 at 16:42
1

Solved this problem! This issue is caused by the Magento Product Video Gallery Extension from Iceberg Commerce. The extension has a feed which offers suggested videos. The feed is not resolving which causes the error.

I basically Disabled 'Feed Suggestions' in:

Configuration > Iceberg Commerce > Video Gallery.

This issue is also reported here.

0

The problem is in the Magento Product Video Gallery Extension from Iceberg Commerce.

Basically the suggested videos isn't working correctly. (Iceberg Commerce is useless for support btw)

My temporary solution, go into your config-> iceberg commerce -> video gallery and disable feed suggestions.

This fixed it immediately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.